Not working with Ubuntu Utopic 14.10 (pre-alpha)

2014-05-22
2014-05-22
  • Jesse Litton
    Jesse Litton
    2014-05-22

    Even after upgrading ffmpeg to the version in the suggested ppa, castawesome (compiled from current git) does not want to start streaming to twitch for me.

    Below is the console output. Note the "no such file or directory" at the end of the output.:

    50
    avconv -f x11grab -show_region 1 -s 1920x1080 -framerate " 25" -i :0.0+0,0 -i -f pulse -ac 1 -i default -vcodec libx264 -filter_complex 'overlay=0:main_h-overlay_h-0' -s 1920x1080 -preset medium -acodec libmp3lame -ar 44100 -threads 1 -qscale 3 -b:a 128k -b:v 400k -maxrate 400k -minrate 400k -g 50 -bufsize 400k -pix_fmt yuv420p -f flv "rtmp://live.twitch.tv/app/redacted"
    Streaming: True
    ffmpeg version 1.2.6-7:1.2.6-1~trusty1 Copyright (c) 2000-2014 the FFmpeg developers
    built on Apr 26 2014 18:52:58 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
    configuration: --arch=amd64 --disable-stripping --enable-avresample --enable-pthreads --enable-runtime-cpudetect --extra-version='7:1.2.6-1~trusty1' --libdir=/usr/lib/x86_64-linux-gnu --prefix=/usr --enable-bzlib --enable-libdc1394 --enable-libfreetype --enable-frei0r --enable-gnutls --enable-libgsm --enable-libmp3lame --enable-librtmp --enable-libopencv --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-vaapi --enable-vdpau --enable-libvorbis --enable-libvpx --enable-zlib --enable-gpl --enable-postproc --enable-libcdio --enable-x11grab --enable-libx264 --shlibdir=/usr/lib/x86_64-linux-gnu --enable-shared --disable-static
    libavutil 52. 18.100 / 52. 18.100
    libavcodec 54. 92.100 / 54. 92.100
    libavformat 54. 63.104 / 54. 63.104
    libavdevice 53. 5.103 / 53. 5.103
    libavfilter 3. 42.103 / 3. 42.103
    libswscale 2. 2.100 / 2. 2.100
    libswresample 0. 17.102 / 0. 17.102
    libpostproc 52. 2.100 / 52. 2.100
    [x11grab @ 0x164ef60] device: :0.0+0,0 -> display: :0.0 x: 0 y: 0 width: 1920 height: 1080
    [x11grab @ 0x164ef60] shared memory extension found
    [x11grab @ 0x164ef60] Estimating duration from bitrate, this may be inaccurate
    Input #0, x11grab, from ':0.0+0,0':
    Duration: N/A, start: 1400716099.719150, bitrate: 1658880 kb/s
    Stream #0:0: Video: rawvideo (BGR[0] / 0x524742), bgr0, 1920x1080, 1658880 kb/s, 25 tbr, 1000k tbn, 25 tbc
    -f: No such file or directory

     
  • Jesse Litton
    Jesse Litton
    2014-05-22

    Nevermind! I figured it out:

    Apparently, the 'Watermark' was somehow set to a directory name instead of a file. After I cleared it out, it began working as expected.

    Thanks!