Installation writing/permisions trouble

Help
eclipse
2006-08-30
2013-04-16
  • eclipse
    eclipse
    2006-08-30

    Hi,
    I have the next warnings during the installation proces. All of them are because it can't write but I don't know where so I don't know where I have to give permisions.
    I would be very pleased if someone could tell me where do I have to give write permisions.
    Thanks in advance.
    David.

    Warning: mkdir() [function.mkdir]: No such file or directory in /usr/local/caravel/install/web_installer.php on line 1231

    Warning: mkdir() [function.mkdir]: No such file or directory in /usr/local/caravel/core/File/hddFile.php on line 127

    Warning: copy(/usr/local/caravel/data/filesystem/dc=default,dc=eclipse01,dc=homeunix,dc=com/caravel/mnF=Welcome.html,mnOD=HTML,mnOD=My Documents,dc=default,dc=eclipse01,dc=homeunix,dc=com/caravel) [function.copy]: failed to open stream: No such file or directory in /usr/local/caravel/core/File/hddFile.php on line 130

     
    • When you ran install.sh it should have asked you for the apache user and group. It then chowns the whole Caravel directory to these. Did you run this file? If you havent you might want to start the install over and start by running this file as root.

      If you did run it then I am not sure why it is having permission problems. First thing make sure you find the correct apache user and group and run the following commands:

      cd  /usr/local
      chown -R apacheuser:apachegroup caravel

      Make sure you put your real user/group in place of apacheuser and apachegroup.

      Hopefully this should fix it, if it doesnt let me know and I'll try to troubleshoot some more.

      -Reuven

       
      • eclipse
        eclipse
        2006-08-31

        Hi Reuven,
        I run the install.sh script and I was asked for the apache user, in my case is nobody:nobody as you can see:
        root     30733     1  0 Aug30 ?        00:00:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        root     30749     1  0 Aug30 ?        00:00:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/mysql/eclipse01.pid
        nobody   30761 30733  0 Aug30 ?        00:00:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30762 30733  0 Aug30 ?        00:00:02 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30763 30733  0 Aug30 ?        00:00:01 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30764 30733  0 Aug30 ?        00:00:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30765 30733  0 Aug30 ?        00:00:03 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30766 30733  0 Aug30 ?        00:00:02 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30790 30749  0 Aug30 ?        00:00:00 /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --user=nobody --pid-file=/opt/lampp/var/mysql/eclipse01.pid --skip-locking --port=0 --socket=/opt/lampp/var/mysql/mysql.sock
        nobody   30808     1  0 Aug30 ?        00:00:00 /opt/lampp_nou/bin/postmaster -D /opt/lampp/var/pgsql/data -S
        nobody   30823 30733  0 Aug30 ?        00:00:03 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30841 30733  0 Aug30 ?        00:00:03 /opt/lampp/bin/httpd -k start -DSSL -DPHP5
        nobody   30983 30733  0 Aug30 ?        00:00:02 /opt/lampp/bin/httpd -k start -DSSL -DPHP5

        The script chown /usr/local/caravel to the right user and group:

        drwxr-xr-x  13 nobody nobody 576 2006-08-30 13:32 /usr/local/caravel/

        I neither understand why it has this trouble because the installation went ok.
        Thanks in advance.
        David.

         
    • After looking at the error mesage I think I see what might be your problem. When it asked you what your caravel base is, did you put:

      dc=eclipse01,dc=homeunix,dc=com/caravel

      If you did, rerun the web install and change this to:

      dc=eclipse01,dc=homeunix,dc=com

      and this should solve your problem. I think we auto detect this so it is posible that it was detected incorrectly.

      -Reuven

       
    • eclipse
      eclipse
      2006-09-02

      Hi Reuven,
      Because I was accessing to the server by the external ip it could not write I changed it for the internal ip and now it can write.
      Now the trouble is that it can not connect to the postgres server. I give to it the ip's server and does not work. I don not know if you know how to solve it.
      Thanks for everything.
      David