#3 0.6.2 don't build

closed
nobody
None
5
2005-04-24
2005-04-19
Anonymous
No

Hello,

Reading the readme :

In the top of the source directory, do the following.
$ ./configure

there is no configure ! (ok, autoconf...)

./configure
creating cache ./config.cache
checking for ocamlc... ocamlc
ocaml version is 3.08.2
ocaml library path is /usr/lib/ocaml/3.08
checking for ocamlopt... ocamlopt
checking ocamlopt version... ok
checking for ocamlc.opt... ocamlc.opt
checking ocamlc.opt version... ok
checking for ocamlopt.opt... ocamlopt.opt
checking ocamlc.opt version... ok
checking for ocamldep... ocamldep
checking for ocamllex... ocamllex
checking for ocamllex.opt... ocamllex.opt
checking for ocamlyacc... ocamlyacc
checking for ocamlweb... true
checking for camlp4o... camlp4o
checking for ocamlfind... install-with-ocamlfind
checking for ocamldoc... ocamldoc
checking for nm... true
checking for objcopy... optpack
updating cache ./config.cache
creating ./config.status
creating Makefile

nice... but now, make :

(echo "(* This file is automatically generated *)" &&\ echo let datadir = \"/usr/local/share/camomile\" &&\ echo let charmapdir =
\"/usr/local/share/camomile/charmaps\" &&\ echo let unimapdir =
\"/usr/local/share/camomile/mappings\") >\ camomileconfig.ml
ocamlc.opt -c -g -I internal -I public -I toolslib -I .
camomileconfig.ml
ocamlc.opt -c -g -I internal -I public -I toolslib -I .
internal/bitsvect.ml
File "internal/bitsvect.ml", line 1, characters -1--1:
Could not find the .cmi file for interface
internal/bitsvect.mli.
make: *** [internal/bitsvect.cmo] Error 2

??

some advice ? thanks

Discussion

  • Logged In: YES
    user_id=373972

    I can not reproduce your problem. Maybe you got the source
    from CVS. In this case, you need to do the following.
    $ autoconf
    $ ./configure
    $ touch .depend
    $ make depend
    $ make
    $ make install

    I will close this bug. If you still have the problem,
    please reopen or submit the new bug.

     
    • status: open --> closed