caliph won't run

Help
2004-09-21
2013-04-29
  • Mark Dagger
    Mark Dagger
    2004-09-21

    Hi, I know there must be something basic I'm missing but anyway, I receive this error on running Caliph (runCaliph) from the dos command line, XP environment:

    Exception in thread "main"  java.Lang.UnsupportedClassVersionError at: /lux/fotoannotation/AnnotationFrame/Unsupported major.minor version 49.0

    This message is followed by a series of line like:

    at java.lang.ClassLoader.DefineClass0(NathiveMethod)

    Emir would do something similar. I don't know enough of Java to try to start to debug myself, so if you could help it would be very appreciated.

    Thank you

     
    • Mathias Lux
      Mathias Lux
      2004-09-22

      Hi, sorry to say but I switched to java 1.5 since the last release. The spring embedding algorithm (package at.lux.grapviz) uses generics to simplify the handling of the used collections (e.g. no need for casts anymore). To run the latest version of Caliph and Emir you will need Java 1.5 (also called "5.0" or "tiger") - see http://java.sun.com/j2se/1.5.0/download.jsp.

      To use a stable build for java 1.4 please use C. v0.9.8 & E. v0.8.1 - in 0.9.9 there's a reference to the java media framework, which is actually never needed - sono need to install.

      Personally I advise all developers to switch to java 1.5 (although it is not yet stable), it can be obtained as release candidate from sun. If we all trust in Sun's sayings we will have final version of java 1.5 (also called "5.0" or "tiger") on 30th of september.  :-)

      regards.
      motte

       
    • Shaun McDonald
      Shaun McDonald
      2004-11-22

      Would it be possible for you to make clear on the project page/download page/within the download that you are using Java 1.5.

      I have a problem that Apple has not yet realased a version of Java 1.5, rumour has it though that Apple has released a development version for developers, but it's only to selected developers.

       
    • Mathias Lux
      Mathias Lux
      2004-11-23

      Done. It's now stated in the title of the release.

       
    • Manu Jam
      Manu Jam
      2004-11-28

      Hello Mathias,

      I've got some problems to launch the last version of Caliph & Ecir.
      I'm working with Eclipse with Java-1.5 under XP. The codes lines as following generate some errors :
      private static HashMap<String, String> relationMapping;

      Can you explain me what is this kind of code ( ...<>) and if it's linked to a specific library.

      thanks a lot

      Emmanuel

       
      • Mathias Lux
        Mathias Lux
        2004-11-29

        Hi!

        I'm afraid the current release version of Eclipse is not able to handle Java 1.5 correctly, a new release is on its way to the best of my knowledge, but I'm not using Eclipse because it is using an own compiler. The <Y,X> are generics, which is a new feature in Java 1.5 worth using :)
        Consult:
        http://java.sun.com/developer/technicalArticles/J2SE/generics/
        for more information.

        As with the IDE: Netbeans 4 RC1 has Java 1.5 support and IntelliJ IDEA already has a stable version with full jse1.5 support (including generics, autoboxing and enumerations, which you will all come across inside the C&E source).

        For eclipse a 1.5 supporting build exists, but this is only what I heard and never tried, I'm not using Eclipse.

        I'm using Java 1.5 because it is - after some time - much more handy to code, especially when using Generics, Enumerations and Autoboxing. Several new classes also have been introduced, to my opinion the one major enhancement is the StringBuilder (very fast array based String handling, but easy to use).

        regards,
          Mathias

         
    • Manu Jam
      Manu Jam
      2004-12-02

      Thanks a lot Mathias,
      I've found the solution to use Java 1.5 under eclipse. If others developpers are interested, they could install the eclipse version 3.1 M3. After they just had to follow instructions to install a : http://www.3plus4.de/eclipse/cheetah.html

      Saving datas with Caliph is not possible. When do you think it will be implemented ?

      thanks
      Emmanuel

       
      • Mathias Lux
        Mathias Lux
        2004-12-06

        well - it already worked fine for me :) Could you give me a bug report including OS, Java version and error message? I will check it.

        best wishes,
        Mathias

         
    • Manu Jam
      Manu Jam
      2004-12-13

      Hello Mathias,
      you're right, it works. But, the saving method generates an error in 95% of cases.

      I give U the bug report :
      [org.lux.fotoannotation.]
      [org.lux.fotoannotation.ImageLoader] Extracing EXIF
      [org.lux.fotoannotation.ImageThumbPanel] Ressources: 4,6M of 16,5M
      [org.lux.fotoannotation.ImageLoader] No MPEG-7 Description found, i've searched for D:\corpus\test\images2\cd1-imm004.mp7.xml
      [org.lux.fotoannotation.ImageLoader] Extracing visual descriptor ColorLayout
      [org.lux.fotoannotation.ImageLoader] Extracing visual descriptor ScalableColor
      [org.lux.fotoannotation.ImageThumbPanel] rescaling image to drawable size...
      [org.lux.fotoannotation.ImageThumbPanel] finished rescaling
      [org.lux.components.ImageThumbPanel] painting image to panel ...
      [org.lux.components.ImageThumbPanel] finished painting
      [org.lux.components.ImageThumbPanel] Painting & scaling lasted 0 ms
      Exception in thread "Thread-3" java.lang.OutOfMemoryError: Java heap space
      [org.mms.components.ImageThumbPanel] Ressources: 0M of 63,6M

      and the interface status is blocked with the message "Extracting visual descriptor EdgeHistogram..."

      I don't know if this error comes from my OS, compiler or the java code.
      For informations, I am under XP, with eclipse and java 1.5.

      Thank you for your help !

      Emmanuel

       
      • Mathias Lux
        Mathias Lux
        2004-12-14

        Looks like there's not enough memory for the EdgeHistogram Extractor and I have not expected an error like this. I will make a bugfix, but this will take some time (scheduled after xmas 2004 :). There are two possible workarounds: Either you can use more memory for your process: just start the java server VM instead of the client VM (cmd-line parameter "-server") and increase the maximum for memory (cmd-line parameter "-Xmx256M" for 256 MegaBytes) if you have enough memory, or: decrease the size of your image, by the way what is the size of the image (pixel height and width and color resolution).

        regards,
        Mathias

         
    • Manu Jam
      Manu Jam
      2004-12-14

      All right, I will test with the java server VM.

      and the size of the image is 1536*1024 with a color resolution of 24 bits.

      Thanks a lot
      Emmanuel

       
    • Manu Jam
      Manu Jam
      2005-01-29

      Hello Mathias,

      Now, I work under eclipse 3.1 M4 with the Java 1.5 compiler.
      But, the following ligne is considered as an error :
      import static java.lang.Thread.sleep;
      in the file BeePanel.java and EmbedderThread.java.

      Can you explain me the reason of this error ?

      Regards,

      Emmanuel

       
    • Ed Davison
      Ed Davison
      2008-10-31

      I know this is old but the original error is what I am experiencing.  I am using Java version 1.5.0_16 and still get this error on Linux.

      Any help would be appreciated as this looks like a very promising software package.

       
      • Mathias Lux
        Mathias Lux
        2008-10-31

        Hi!

        I'm not sure, but I think I used Java 1.6 for compiling it. I'd advice to install ant and compile it for 1.5

        regards,
        Mathias