#59 Segmentation fault at mged

open-later
Cliff Yapp
8
2010-06-28
2010-06-15
orkun akay
No

Hi,
I compiled BRLCAD 7.16.8 from source. When I try to run mged I get Segmentation fault. I read support request no 2976166 but in my case I've already have compiled BRLCAD myself on Mac OS X 10.6.3. Attached is the problem report generated.
Thanks in advance.

Discussion

  • orkun akay
    orkun akay
    2010-06-15

     
    Attachments
  • Sean Morrison
    Sean Morrison
    2010-06-15

    Thanks for the report. It's a known issue, but one that cannot be locally reproduced so thanks for the crash log. As for a workaround, you may be able to --enable-opengl during configure, make clean and re-make. A build with the dm-ogl interface enabled may work where the dm-X interface does not -- it's at least something to try.

     
  • Sean Morrison
    Sean Morrison
    2010-06-15

    • priority: 5 --> 8
    • status: open --> open-accepted
     
  • orkun akay
    orkun akay
    2010-06-15

    Thank you for your quick response. I tried with --enable-opengl with no success, getting segmentation fault again. I've attached the new problem report.
    It seems I'll have to wait for further releases..

     
  • orkun akay
    orkun akay
    2010-06-15

    • status: open-accepted --> open-wont-fix
     
  • orkun akay
    orkun akay
    2010-06-15

     
  • Sean Morrison
    Sean Morrison
    2010-06-28

    We're working on a solution that will fix this problem and move us closer towards a native Aqua interface on Mac. Thanks for your patience while we work through this.

     
  • Sean Morrison
    Sean Morrison
    2010-06-28

    • assigned_to: nobody --> starseeker
    • status: open-wont-fix --> open-later