#36 compiling brlcad 7.10.04

release 7.10
open
nobody
5
2009-09-18
2009-09-18
No

After compiling from Sorceforge.: brl cad Sorge version 7.10.04.tar.gz I found out that mged is not incuded. I have been trying for several days to install brlcad but without luck. I need some help. I have been reading a hole lot of instructions but most of them must be out of date. I am running Ubuntu linux on an old 32bit pc and are a new beginner regarding Linux.

Discussion

  •  
    Attachments
  • Tom Browder
    Tom Browder
    2009-09-18

    Any reason you're not using the latest version of BRL-CAD?

    What happened when you tried the build? Can you provide the compile log?

     
  • I have been trying to install version 7.10.04 without any luck.
    I thought I attached the compile.log file as config.log.tar.gz

     
  •  
    Attachments
  • Erik Greenwald
    Erik Greenwald
    2009-09-21

    From the compile log, it'd seem that you do not have the X11 development packages installed, which will be required to get a GUI on Linux. Look for packages like "libX11-dev", "libXi-dev" and "libxt-dev". When you have the right packages installed, the "X11 support ....." line at the end of the "./configure" run will be set to "yes". Please consider using 7.14.8, the version you're looking at is two years old and many things have been fixed or improved.

     
  • config-log-7.10.8

     
    Attachments
  • I tried to compile and install 7.10.8. I xtared it to my local /home/gunnar/Desktop/ and run ./config from there. First I removed older version from /usr/brlcad/ directory. I don't know where to I shall xtar the sorce code and what preparations to make regarding directories etc. AAttached is the config.log file.

    Thanks