Firstly, thanks for the reply. 
I ran mged and archer from the command line.
On running mged from the command line, the output is a segmentation fault error message, along with the process id. Running archer gives the same output. 



On Tue, Feb 12, 2013 at 11:44 PM, Christopher Sean Morrison <brlcad@mac.com> wrote:

On Feb 07, 2013, at 01:22 PM, Prashanth Srinivasan <prashanth93@gmail.com> wrote:

The machine I'm on runs Ubuntu-64-bit 10.04. Accordingly, I downloaded the brlcad_7.22.0-0_amd64.deb file.
I installed the package using dpkg -i brlcad_7.22.0-0_amd64.deb.
The output from dpkg seemed fine till this popped up :
 
Prashanth,

Those errors seem unrelated, but are certainly something to look into for the .deb maintainer.

brl-cad does not load. On opening archer, the logo (of Archer) is displayed for half a second, and then the windows automatically closes.
On running mged, I get a terminal opening, and again closing in less than a second.
 
What happens if you try to run mged or archer from the command line, not by using the icon or menu options?
 
Does the problem have to do with ubuntu 10.04? Are there any missing packages to install?
 
Hard to say, there's not enough information.

Cheers!
Sean


------------------------------------------------------------------------------
Free Next-Gen Firewall Hardware Offer
Buy your Sophos next-gen firewall before the end March 2013
and get the hardware for free! Learn more.
http://p.sf.net/sfu/sophos-d2d-feb
_______________________________________________
BRL-CAD Users mailing list
brlcad-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/brlcad-users




--
Prashanth Srinivasan,
3rd year Undergraduate,
Dept. of Mechanical Engineering,
IIT Madras