Run on freeBSD 5.5

Help
2006-03-31
2013-04-22
  • Marcin Sloma
    Marcin Sloma
    2006-03-31

    Hi.
    First of all brl-cad had itself installed in to /usr/local/ not in /usr/
    When runing mged i get folowing output:

    [luzer@localhost /usr/local/brlcad/bin]$ mged
    Initializing and backgrounding, please wait...Unable to locate where BRL-CAD 7.6.6 data resources are installed
    while searching:
            BRLCAD_DATA environment variable [/usr/local/brlcad/share/brlcad/7.6.6]
            BRLCAD_DATA compile-time path [/usr/local/brlcad/share/brlcad/7.6.6]
            BRLCAD_ROOT common data path  [share/brlcad/7.6.6]
            BRLCAD_ROOT common data path  [/usr/local/brlcad/share/brlcad]
            BRLCAD_ROOT common data path  [/usr/local/brlcad/share]
            BRLCAD_ROOT common data path  [/usr/local/brlcad]
            current directory

    This release of BRL-CAD expects data resources to be at:
            /usr/local/brlcad/share/brlcad/7.6.6

    You may specify where to locate BRL-CAD data resources by setting
    the BRLCAD_DATA environment variable.  For example:

    for csh/tcsh users:
            setenv BRLCAD_DATA /path/to/brlcad/data
    for sh/bash users:
            BRLCAD_DATA=/path/to/brlcad/data ; export BRLCAD_DATA

    Unable to find 'lib/tcl8.4' within the BRL-CAD software installation.
    This copy of BRL-CAD may not be properly installed.

    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    ogl_open: Can't get an appropriate visual.
    Done

    Any help?
    Thx

     
    • Sean Morrison
      Sean Morrison
      2006-04-08

      There are two issues, the first being that it cannot seem to find lib/tcl8.4 where it expected it.  If you run "find /usr/local/brlcad -name tcl8.4 -type d" what does it report?

      The second issue is that even had that worked, MGED was unable to open a window that was compiled to use OpenGL.  Both issues can be worked around, but you'll have to first find that tcl8.4 directory and put it somewhere it expects to find it.  Once you get that in place, run mged -c and select "X" instead of the default "ogl" that it was compiled for (or install OpenGL libs if you can)"  OpenGL isn't required, it was simply compiled that way for that binary.

       
    • Hi Sean.. I found this old thread and thought it better to continue this thread. I have a working glx (glxgears runs), but I had a similar problem

      What are the variables that have to be set in a script? I tried what you mentioned here and it works but I wouldn't expect all FreeBSD users to do this:

      ___________
      etoile# uname -a
      FreeBSD etoile.cable.net.co 6.1-RELEASE FreeBSD 6.1-RELEASE #1: Fri May 12 00:18:58 COT 2006     root@etoile.cable.net.co:/usr/src/sys/amd64/compile/DIMENSION  amd64
      etoile# find /usr/local/brlcad -name tcl8.4 -type d
      /usr/local/brlcad/lib/tcl8.4
      etoile# ./mged
      Initializing and backgrounding, please wait...dm-ogl: Can't make display lists for font.
      Done
      etoile# ./mged -c
      BRL-CAD Release 7.8.0   Geometry Editor (MGED)
          Tue Apr 11 01:32:25 EDT 2006, Compilation 1
          sean@intelligentcode.com:/archive/BRL-CAD/brlcad/src/mged

      attach (nu|X|ogl)[nu]? X
      mged>