Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

OSX 10.6.5 incorrect Tk version.

Help
Arkturaas
2010-12-12
2013-04-22
  • Arkturaas
    Arkturaas
    2010-12-12

    I am running Mac OS 10.6.5

    I configured brl-cad with the '-enable-tk -enable-tcl -with-ogl' flags.

    The error I ran into is shown in the following terminal session.


    Console: mged
    Can't find a usable tk.tcl in the following directories:
        /usr/brlcad/lib/tk8.5

    /usr/brlcad/lib/tk8.5/tk.tcl: version conflict for package "Tk": have 8.5.9, need exactly 8.5.8
    version conflict for package "Tk": have 8.5.9, need exactly 8.5.8
        while executing
    "package require -exact Tk  8.5.8"
        (file "/usr/brlcad/lib/tk8.5/tk.tcl" line 20)
        invoked from within
    "source /usr/brlcad/lib/tk8.5/tk.tcl"
        ("uplevel" body line 1)
        invoked from within
    "uplevel #0

    • "

    This probably means that tk wasn't installed properly.

    MGED Aborted.


    I am not certain what to do in response to this error. It looks like mged is linking to a tk installation inside the brl-cad library, so I am somewhat confused as to how my tk version is not correct.

    Thanks

     
  • Cliff Yapp
    Cliff Yapp
    2010-12-14

    Do you have Tcl/Tk 8.5.9 installed on your system?  It looks like somehow Tcl/Tk is finding libraries for a version other than that which was compiled.