openSUSE reloaded (12.2)

Help
2013-04-03
2013-04-22
  • Oliver Gloth
    Oliver Gloth
    2013-04-03

    Hi,

    I have some problems again trying to get BRL-CAD to work on openSUSE. This time it is SUSE 12.2 and BRL-CAD 7.22. The RPM file does not work because of a ZLIB conflict. Trying to compile I get an compiler error:

    error: call to function ‘rt_arb_centroid’ without a real prototype

    Is this a known problem? If not I will provide some more information.

    Cheers,
    Oliver

     
  • Oliver Gloth
    Oliver Gloth
    2013-04-03

    UPDATE: it compiles fine with gcc-4.6 (openSUSE 12.2 normally uses 4.7). CUDA also does not like 4.7, for that reason I have 4.6 installed as well.

    BRL-CAD appears to work, but I cannot link my own stuff against librt, because it complains about missing openNURBS. That appears to be something that might be within reach - tomorrow, though.

    So, I guess that I will be able to get everything to work on 12.2 - You might want to look into the gcc-4.7 issue, though.

    Cheers,
    Oliver