error compiling bwish - 7.12.4

2008-08-03
2013-04-22
  • I have a problem which looks like other compilation problems recently reported, but not quite - and the fix suggested does not seem to help.

    It fails when linking bwish, and complains about an undefined reference to TclVarHashCreateVar.

    I have successfully compiled 7.10.2 on this machine. This machine is running Debian unstable.

    TclVarHashCreateVar does appear to be present in both Tcl 8.4 and 8.5,
    and both libtcl8.4.so and libtcl8.5.so are present in /usr/lib.

    I have tried running ./configure with --enable-all, but this does not help.

    The suggestions offered include the idea that this is due to an incompatible version of I presume Tcl.  Which raises another question - what are the dependencies.  I have searched high and low on the site and have been unable to find such a list.  It really would be useful to have such a list either in the README or on the web site.

    David

     
    • Sean Morrison
      Sean Morrison
      2008-08-03

      David,

      Did you run "make clean" or start from a fresh tarball when you tried ./configure --enable-all ?  If that doesn't work, that'd be worth posting a bug report (to our bug tracker) including your config.log and entire build output.  If you "enable everything", there shouldn't be any external dependencies.  That's why there isn't a list.

      The INSTALL file speaks briefly to that point.  We bundle all of our required dependencies so you don't have to get/install anything.  At least everything minus a few fundamentals like libc, a shell, a compiler, etc.  If you start from ./autogen.sh, then you must also have the GNU Build System tools installed and all of their dependencies but then you're behaving as a project dev and are expected to be fluid with the compilation process.

      As for undefined references to TclVarHashCreateVar, the only issue that comes to mind is 8.4 vs 8.5 so if --enable-all doesn't work on a clean compile (which will use 8.5), then please send a report.

      Cheers!
      Sean