#324 Unable to build 7.22.0 on OS X 10.6

unexpected behavior
closed-fixed
Sean Morrison
5
2012-09-14
2012-09-12
Cameron
No

I am trying to build BRL-CAD 7.22.0 from source because the .dmg download won't open, and I get the following error:
Scanning dependencies of target bw-pix
/Users/user/Documents/brlcad-7.22.0/src/other/boost/boost/graph/graphviz.hpp: In function ‘std::string boost::escape_dot_string(const T&) [with T = long unsigned int]’:
/Users/user/Documents/brlcad-7.22.0/src/other/boost/boost/graph/graphviz.hpp:71: internal compiler error: output_operand: invalid expression as operand
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://developer.apple.com/bugreporter> for instructions.
[ 28%] Building C object src/util/CMakeFiles/bw-pix.dir/bw-pix.c.o
{standard input}:121570:End-of-File not at end of a line
{standard input}:122382:End-of-File not at end of a line
{standard input}:unknown:Partial line at end of file ignored
{standard input}:unknown:Undefined local symbol LC62
{standard input}:unknown:Undefined local symbol LC63
Linking C executable ../../bin/bw-pix
make[2]: *** [src/libpc/CMakeFiles/libpc.dir/pcNetwork.cpp.o] Error 1
make[1]: *** [src/libpc/CMakeFiles/libpc.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking C executable ../../bin/bw-imp
[ 28%] Built target bw-pix
[ 28%] Built target bw-imp
/Users/user/Documents/brlcad-7.22.0/src/other/boost/boost/graph/graphviz.hpp: In function ‘std::string boost::escape_dot_string(const T&) [with T = long unsigned int]’:
/Users/user/Documents/brlcad-7.22.0/src/other/boost/boost/graph/graphviz.hpp:71: internal compiler error: output_operand: invalid expression as operand
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://developer.apple.com/bugreporter> for instructions.
{standard input}:121570:End-of-File not at end of a line
{standard input}:122382:End-of-File not at end of a line
{standard input}:unknown:Partial line at end of file ignored
{standard input}:unknown:Undefined local symbol LC62
{standard input}:unknown:Undefined local symbol LC63
make[2]: *** [src/libpc/CMakeFiles/libpc-static.dir/pcNetwork.cpp.o] Error 1
make[1]: *** [src/libpc/CMakeFiles/libpc-static.dir/all] Error 2
make: *** [all] Error 2

I am no programmer but it appears that the problem starts with an internal compiler error in graphviz.hpp and then this makes other threads have errors (i'm compiling with make -j4). If this helps, I also received the following warnings in the configuration process (it still configured and let me start compiling):
-- Could NOT find ADAPTAGRAMS (missing: AVOID_LIBRARY AVOID_INCLUDE_DIR)
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)

If there is any more info that would be useful let me know and I'll do my best to provide it.

Discussion

  • Sean Morrison
    Sean Morrison
    2012-09-12

    Due to some glitch in the upload interface, the DMG file only partially uploaded. That's why it wouldn't open. A new version was just uploaded again right before your bug submission. We verified that it is a complete upload (124MB), so you should be good to go.

    A lot more information would be required to trace down the source of that compilation failure. It doesn't look to be a BRL-CAD issue and is not something we're encountering on any platform (Mac included). The line in graphviz.hpp:71 is correct.

     
  • Sean Morrison
    Sean Morrison
    2012-09-12

    • assigned_to: nobody --> brlcad
    • status: open --> closed-out-of-date
     
  • Cameron
    Cameron
    2012-09-13

    Ok, the dmg opens just fine and I can drag the .app to the Applications folder, but when I try to run it, it shows an error message:
    dyld: Symbol not found: __cg_png_create_info_struct
    Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO

    It also says that it expects the symbol to be in the libpng15.15.10.0.dyld in the lib folder of the .app package. Is this the dependency on a non-default library that is mentioned in the README file as being a problem with the first posting of the .app for 7.22.0?

     
  • Sean Morrison
    Sean Morrison
    2012-09-14

    I just discovered that issue earlier today as well, apologies on the complications. A new version of the DMG was just uploaded that fixes the png issue.

     
  • Sean Morrison
    Sean Morrison
    2012-09-14

    • status: closed-out-of-date --> closed-fixed