#268 graphics by MGED versus Archer

closed-later
Bob Parker
3
2010-07-08
2010-07-07
andre anckaert
No

Lately Sean gave me some good advice about how to put a toyjeep on the MGED graphics-window.

http://fotoalbum.seniorennet.be/incl/getimage2.php?imageid=1574312&albumid=18832&typeid=4:
This URL shows the image of what hyappened; a lot of abracadabra got dumped in the bottom-info but no image appreared.

I suspected that perhaps my Windows XP Pro SP3 sat in the way and tried what Archer would do:

http://fotoalbum.seniorennet.be/incl/getimage2.php?imageid=1574308&albumid=18832&typeid=4

I have some unanswered questions about Archer but at least it shows me this toyjeep. With the help of my Windows I suppose. Why can't my Windows help MGED doing its job?

I do not know if this is really a bug in MGED, but it is surely bugging me. And I put it here also because I am not able, or capable, to start, or extend, a thread on the users-list, although I am now duly registered there. Everything there stays "read only". Is that also a bug??

Yours faithfully.

André Anckaert from Belgium.

Discussion

  • Sean Morrison
    Sean Morrison
    2010-07-08

    The wireframe isn't displaying in MGED after you run "draw" and that is the cause of most of the problems you're facing. I highly suspect it's some incompatibility with your video card with that Windows compilation, but it's hard to say without additional diagnostic information about your specific system. Regardless, the version you're running is no longer productively debuggable as there's a new binary release coming very soon.

    One thing you can try, however, is to turn the framebuffer on and off (on the raytrace control panel). On that same control panel (on the menu), try toggling from overlay to underlay and back. Finally, you can also try changing the color of the background and/or the wireframe color on the options menu.

    Either way, thank you for the report. When the new release is made, please do be sure and try it and see if you're still experiencing the same problem.

     
  • Sean Morrison
    Sean Morrison
    2010-07-08

    This issue has been resolved in the latest (unreleased) version of the source code. Thank you for bringing the issue to our attention! You're welcome and encouraged to test and make sure this issue is resolved after the next source release of BRL-CAD.

     
  • Sean Morrison
    Sean Morrison
    2010-07-08

    • labels: --> Geometry Editing
    • milestone: --> other bug / workaround
    • priority: 5 --> 3
    • assigned_to: nobody --> bob1961
    • status: open --> closed-later