#243 Ray-trace after region edit fails

open
Bob Parker
Raytrace (49)
7
2011-06-07
2010-02-18
Bob Anderson
No

When using 7.14.8 in Windows, the raytrace functions fail after editing a solid or region. The raytracer (rt, nirt) works perfectly fine up until the point something is edited, whether it be a solid or booleans within a region. After that, a "Raytrace Failed" message appears when trying an "rt" or an "nirt" command. This has occurred on several of our machines which probably means its not computer specific or path related. The only fix is to shut down the model and re-open which is quite annoying. Has anyone else seen this error? I sometimes get frustrated and revert back to 7.12.6.

Discussion

  • Sean Morrison
    Sean Morrison
    2010-04-06

    Bob, this is the first I've heard of this issue, but there was a problem identified/fixed very recently with how binaries were being searched on Windows. Our upcoming 7.16.8 release should have a fix (and has a lot more Windows testing in it) but I'll work with you on this issue as well with our 32-bit/64-bit Windows testing outside the tracker system. Still working on that test build for you.

     
  • Sean Morrison
    Sean Morrison
    2010-04-06

    • assigned_to: nobody --> bob1961
    • milestone: --> serious bug / workaround
    • status: open --> pending-fixed
     
  • This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending-fixed --> closed-fixed
     
  • Sean Morrison
    Sean Morrison
    2011-06-04

    Reopening this issue since it's apparently still broken as of 7.18.0

    Bob, how exactly are you editing a solid or region? Command-line commands? Which ones exactly? Using the GUI? Does this work for you:

    Z
    make sph sph
    B sph
    rt
    sed sph
    tra 100 0 0
    accept
    rt

    You should get two raytrace windows with a simple sphere in them. If it does work, try to come up with your own exact sequence of commands or actions to results in failure.

     
  • Sean Morrison
    Sean Morrison
    2011-06-04

    • status: closed-fixed --> open
     
  • Bob Anderson
    Bob Anderson
    2011-06-07

    I did the sample case you suggested and I cannot duplicate the problem. Now I know how the wife feels when she tries to explain whats wrong with the car. I also placed the sphere in a region, displayed the region, edited the sphere and pressed accept. Raytraced fine. I then made another sphere and subtracted it from the first in the same region. Raytraced fine.

    I can't seem to duplicate the problem with these simple cases which leads me to believe that the problem is more complex than my initial explanation. When it happens again I will take a screen shot of the error and explain what I was doing when the error occurred.

     
  • Sean Morrison
    Sean Morrison
    2011-06-07

    I have no doubt that you're running into a bug, so the screenshot isn't really necessary. We just need to find a reliably repeatable sequence or reliably failing geometry so we can reproduce the problem on our end. Once we can reproduce the problem, we can fix it.

    The problem could be specific to a particular .g file, could be a type of geometry, could be the particular complexity, could be a lot of things. That's why it's a complete stab in the dark hunting blind until we can reproduce. Way too many things to just guess, especially since all of our testing and daily use don't exhibit a problem.

    So when you run into the problem again, restart MGED and try to get it to happen again with fewer actions. The fewest keystrokes and button clicks or at a minimum, find geometry that consistently fails.

    If it's geometry that can be made public, post it with the actions that fail and we'll have a solid test case to debug. If it's geometry that can't be made public, but can be e-mailed confidential, then that works too.

     
  • Sean Morrison
    Sean Morrison
    2011-06-07

    • priority: 5 --> 7