Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#49 Note sounds with mouse but not with MIDI keyboard

admin
closed-invalid
Nick Copeland
5
2009-07-08
2009-06-15
David Bridson
No

This is a strange bug. I'm using bristol 0.40.3 compiled from source on Ubuntu 9.10 Alpha 2 on an AMD X2 64-bit. In bristol, if I click a note with the mouse, it sounds perfectly. However, if I use my MIDI keyboard with bristol, when I press a key, the key on the screen depresses as expected, but the related note does not sound. I am starting bristol with:

startBristol -v -audio alsa -midi alsa -b3

And connecting my keyboard with:

aconnect 20 128

As I said, the strange thing is that bristol seems to be receiving the MIDI events properly because it updates the keys on-screen, the only problem being that the sound is not emitted when pressing a key on the MIDI keyboard. Again, when just using the mouse to press keys on-screen, the sound is fine, even in the same session! I haven't tested all emulations but this happens with all of the ones I usually use - B3, Mini and Voyager.

Bug aside, thanks for a great programme :-)

Discussion

  • Nick Copeland
    Nick Copeland
    2009-06-15

    Hi David,

    Yes, that is strange. The value you give for aconnect looks correct - 128 is typically the engine so connecting to it should give you MIDI control. Now the application consists of two parts: brighton and bristol. Bristol is the engine and it should reside on 128 if you do 'aconnect -o'. The GUI then starts on 129 and if you aconnect 20 129 then you will see the GUI move as well. If you want both GUI and engine to respond to MIDI you have to connect both of them. It goes like like this: if you only want to play the engine then you only need one connection. If you want to have controller tracking a midi master surface you need to connect it to the engine (it may or may not be the same aconnect ID as the master keyboard). If you want to see keys move in the GUI as well as be played (which is actually more eye candy than functional) then you need to aconnect the master keyboard to both bristol and brighton.

    Good, it looks like the GUI has connected to 128 and that is unusual. What do you get from the following commands

    startBristol -b3
    aconnect -o
    ps ax | egrep '(bristol|brighton)'

    Using -audio and -midi sometimes gives unexpected results, possibly related to the 64 bit version (I only develop on 32 bit as my system is not the newest). You might want to also try the following, the symbolic name might work better than the actual index number:

    aconnect 20 bristol:0

    When we get this working I would be interested in hearing how you get on with the 64bit system.

    Regards, Nick.

     
  • Nick Copeland
    Nick Copeland
    2009-06-15

    • labels: --> Midi Library
    • milestone: --> admin
    • assigned_to: nobody --> ncopeland
     
  • David Bridson
    David Bridson
    2009-06-15

    Hi Nick,

    Now, after filing the bug report, I can no longer reproduce this on my system. At some point when I ran aconnect -io, I was just getting one entry under 128. Now, I have two under 128 and 129 and everything works as you describe, but I didn't change anything! Perhaps some gremlins in my system :-)

    I have to say, now that I've got it working again, bristol seems to work absolutely great. I don't think I'd used Bristol since 0.9 (the version which, up until recently shipped as default in Ubuntu) and I have to say you've made some real progress in the emulations. They sounded good before but now they sound so much closer to the original instruments, at least as far as the B3 is concerned.

    I'll probably be using Bristol quite a bit now I've got it working so if there's anything I can help out with on the 64-bit version, in terms of testing, debugging, etc., please let me know. But, thanks for producing a great piece of software :-)

    Best regards,
    David

     
  • Nick Copeland
    Nick Copeland
    2009-06-15

    Good, it works. I would not believe your comments on Gremlins in the system other than that I have had them as well from time to time - they come and go!

    You have 0.40.3 installed, you might want to check the release notes for 0.40.4 for some ALSA improvements (the problems were very dependent on system release and ALSA version - you may or may not see them).

    Let's put this report on hold for a time. If it now works then see how you get on with 64 bit, if issues turn up we can take care of them.

    Regards, Nick

     
  • Nick Copeland
    Nick Copeland
    2009-07-07

    Case closed as resolved.

     
  • Nick Copeland
    Nick Copeland
    2009-07-07

    • status: open --> pending-invalid
     
  • Nick Copeland
    Nick Copeland
    2009-07-08

    • status: pending-invalid --> closed-invalid
     
  • Hi Nick,

    I've been using Bristol quite successfully since I posted the bug. The info you posted was really helpful in understanding how Bristol works. However, last night I had the same issue with brighton being listed by aconnect -io but not bristol. This is strange because it really does seem to work 95%+ of the time and I can't figure out anything which is configured differently when it fails to work on occasions?!

    Best Regards,
    David

     
  • Nick Copeland
    Nick Copeland
    2009-07-10

    Hi David,

    The only way I can think to proceed is to get the messages output from a failed sequence: if you use startBristol in a terminal with whatever options you use it will spurt out some operational messages showing what it is attempting to do, especially important during the startup sequences.

    If you can post the 'startBristol' through to the last messages which are normally

    ...
    ...
    brightonWorldChanged(700 400 10 10)
    going operational: 8bd6008, 8be5a50

    That might help to localise the issue.

    Regards, nick

     
  • Nick Copeland
    Nick Copeland
    2009-07-17

    Hi David,

    A couple of other things. You are giving options here for -audio alsa -midi alsa, I would avoid that and try -alsa, this should configure defaults for both interfaces. The -audio and -midi flags typically remove all the default values so may require some other flags to allow them to work correctly. Also, did you ever get hold of 0.40.5? This unreleased code does have problems with the MIDI interface registration. They will be fixed before 0.40.5 is released but still give problems at the moment and are due to changes requested for 0.40.5 that are not yet complete.

    Regards, Nick.