Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Tool tip bug

dis-play
2014-04-06
2014-04-17
  • dis-play
    dis-play
    2014-04-06

    Hi.

    I don't know if anyone noticed, but theres a bug with the tooltips (tested on Win 8).
    When hovering over an item in the job list to see the tooltip and the list updates, e.g. because encoding of a track finished, the tooltip disappears, but leaves a border.

    I hope you can fix that.

     
  • Robert Kausch
    Robert Kausch
    2014-04-06

    Thank you for reporting this!

    I noticed that frame before a few times, but was unable to figure out what's causing it (other than that it's the shadow of a tooltip). Thanks to your description I can finally reproduce it and will hopefully be able to fix it soon.

    Best regards,
    Robert

     
  • Robert Kausch
    Robert Kausch
    2014-04-07

    Good news! I was able to identify and fix the bug.

    The problem occurred because ShowWindow was called from the conversion thread to hide the tooltip window. You need to use ShowWindowAsync, however, when working with windows of a different thread.

    The fix will be included in the next snapshot and in fre:ac 1.0.22.

     
  • dis-play
    dis-play
    2014-04-17

    Thanks alot!

     
  • dis-play
    dis-play
    2014-04-17

    And I think you should also check the behaviour with other windows like the database-query windows (where you can choose a data set) because sometimes these windows get lost behind the main window, and when I close the main window, the freac process is still running, leaving these windows open.