access to CDrom denied

2007-05-10
2013-12-09
  • Hi there,

    I've just installed Bonkenc. When I run it up, I get the message :

    Access to the CDROM was denied by Windows. Please contact your administrator
    to be granted the right to access the CD-ROM drive.

    I'm logged in as an ordinary user to a windows XP workstation. The CDROM
    isn't shared in any sense. What on earth does this message mean?

    Any help would be appreciated.

    Paul S

     
    • Robert Kausch
      Robert Kausch
      2007-05-10

      By default, Windows XP restricts CD-ROM access to users with administrator privileges so BonkEnc will not be able to access CD-ROM drives when run under an ordinary user account. To fix this, follow these steps:

      1. Log onto the computer with a user account that has admin rights (i.e. "Administrator")
      2. Go to Start->Settings->Control Panel->Administrative Tools->Local Security Policy
      3. In the window that appears, open the folder "Local Policies" and then the sub-folder "Security Options"
      4. Change the option "Restrict CD-ROM access to locally logged-on users" to "Enabled"
      5. Close the windows. You're done.

      After changing that option, a reboot may be required.

      BonkEnc should start without the error message now and should be able to access the CD-ROM drives.

       
      • Edward Doherty
        Edward Doherty
        2013-11-30

        Hi,

        I'm getting the same error message using Windows 7 Home Premium, even when I'm logged on as administrator.

        When I go to Control Panel->Administrative Tools, there is no link to Local Security Policy

        Where can I find this, so I can use freac to rip cds?

        Any help appreciated

        thanks.

         
        • Robert Kausch
          Robert Kausch
          2013-11-30

          This should not be an issue on Windows 7, so I wonder why it would deny CD-ROM access to fre:ac for you.

          The Local Security Policy entry does not exist on Windows 7 Home Premium. It is available on Professional editions of Windows only. However, I don't think this is the problem here anyway. Still, you can try to use a tool like Nero BurnRights to change that setting. It's available for free download from Nero's website. I don't know if it will work on Windows 7 Home Premium, though.

          A more likely possibility might be some application or service running in background and locking the drive for exclusive access. Please check that first.

           
          • Edward Doherty
            Edward Doherty
            2013-12-01

            Sorry for my ignorance, but how do I go about checking that?

             
            • Edward Doherty
              Edward Doherty
              2013-12-01

              I should have said that the disc drive is working normally otherwise - it's only when I run fre:ac that I get the error message.

              I've tried Nero Burnrights, but it made no difference.

              I've also had a look through services, but can't see anything that might relate to this problem.

               
              Last edit: Edward Doherty 2013-12-04
              • Edward Doherty
                Edward Doherty
                2013-12-07

                Problem solved.

                It seems that access was being denied not by Windows, but by Comodo firewall..

                I tried uninstalling freac and reinstalling it, and noticed that Comodo was sandboxing it - after I told it not to freac started working properly

                 
                • Robert Kausch
                  Robert Kausch
                  2013-12-09

                  Great! I'm glad you solved it. Thanks for reporting the solution here!

                   
    • Hi Robert,

      Thanks for that. After a reboot, it works well.

      I'm just a little puzzled as to why it's necessary to do that. Other utils
      I have access the cdrom without changing the local security policy?

      BTW, I very much like the no-nonsense, clean interface. Seems
      to work well too.

      regards

      Paul S