#63 lpthread in build configuration file

before_v1.4_release
open
nobody
None
5
2012-10-30
2012-07-11
Russ
No

I'm running on Fedora 12 (!) uname reports Linux 2.6.32.26-175.fc12.x86_64, and tried to build Bochs with the following: sh ./configure --prefix=$PREFIX --enable-debugger --enable-debugger-gui --enable-disasm --with-x --with-x11 --enable-docbook --enable-x86-debugger. The ensuing compile failed because it could not find "pthread_create." I checked config.log, and it reported that it couldn't find "-lpthreads" with an 's' on the end. The library is called "-lpthread" on my setup, not pthreads. I worked around by putting "env LIBS=-lpthread" in front of the configure command.

There is a second problem. Despite config.log showing failure to find the -lpthreads library, the configure step continued on rather than aborting and reporting an error.

Thanks - Russ

Discussion

  • Volker Ruppert
    Volker Ruppert
    2012-10-30

    • milestone: --> before_v1.4_release
     
  • Volker Ruppert
    Volker Ruppert
    2012-10-30

    This item is not related to the website, but it should be moved to the "Bugs" section.