Startup error - 'NoneType' object...

Help
Shrimp
2005-01-06
2013-05-01
  • Shrimp
    Shrimp
    2005-01-06

    Hi there

    I've been using Boa for a while now on Windows, and now I'm trying to get it to run on my Debian system - without much luck unfortunately.

    When I try to run it, I get a message box telling me "'NoneType' object has no attribute 'Destroy'" and it bombs out, dumping the following to the console:

    <rest of startup>
    ...
    importing Explorers.DAVExplorer
    importing Explorers.SSHExplorer
    Traceback (most recent call last):
      File "/usr/bin/boa-constructor", line 659, in ?
        main()
      File "/usr/bin/boa-constructor", line 641, in main
        app = BoaApp()
      File "/usr/bin/boa-constructor", line 460, in __init__
        wxApp.__init__(self, false)
      File "/usr/lib/python2.3/site-packages/wxPython/wx.py", line 1951, in __init__    _wxStart(self.OnInit)
      File "/usr/bin/boa-constructor", line 495, in OnInit
        self.main.componentSB, self, self.main)
      File "/usr/share/boa-constructor/Editor.py", line 296, in __init__
        self.setupToolBar(viewIdx = 0)
      File "/usr/share/boa-constructor/Editor.py", line 481, in setupToolBar
        Utils.duplicateMenu(self.blankEditMenu), 'Edit').Destroy()
    AttributeError: 'NoneType' object has no attribute 'Destroy'

    I'm running Debian Unstable (AMD64), Boa Constructor 0.3.0-3, and wxPython 2.5.3.2 - all installed via apt.

    Any help would be greatly appreciated.

    Thanks.

     
    • Hi,

      You need to use wxPython 2.4.x with Boa 0.3.x

      Only Boa 0.4 is compatible with wxPython 2.5.x

      See you
      Werner

       
    • Shrimp
      Shrimp
      2005-01-09

      Ahh, ok, thanks ;)