Global name 'wx' is not defined

Help
Anonymous
2004-04-12
2004-04-27

  • Anonymous
    2004-04-12

    Hi,

    Trying to get Boa going on my WinXP Pro system. I'm running Python 2.3.3 with wxPython 2.5. The message in the subject line is all I get when I try to load Boa.py. Any suggestions?

    Thanks,
    Matt

     
    • Matt,

      Boa does not yet support wxPython 2.5, you should install wxPython 2.4.x and then things should work.

      Riaan mentioned in some other posting either here or on "gmane.comp.ide.boa-constructor.user" that he is trying to get Boa 0.3 out soon and will then work on getting Boa to support wxPython 2.5.

      See you
      Werner

       
    • David Miller
      David Miller
      2004-04-27

      It would have saved me about 3 hours if this itsy-bitsy detail would have been someplace obvious on the Boa website. It should not be hard to add what many web sites include as a "requirements" list.

      Here is what we find under the "detailed" installation instructions:

      "Download wxPython from www.wxpython.org . Get the version built for the Python version installed..."

      So I have Python 2.3 and I do what the wxPython site instructs. I download the wxPython version for this version of Python.

      This generality is sufficient if the system works with any version of Python and any version of wxPython, etc., but when it doesn't it only makes sense to keep a current requirements list or to include these details in the installation instructions.

      Boa is a fine product. This kind of frustration tarnishes what is otherwise a creative and useful tool.