can't get boa started

  • Peter Galfi
    Peter Galfi

    Hi all,

    I installed boa constructor 0.6.1, but I can't get the program started. I tried all kind of versions of wxPython and Python by now from 2.3 to 2.5 (with the appropriate wxPython versions), but it always ends with the same error:

    ImportError: MemoryLoadLibrary failed loading wx\_core_.pyd

    It should be something basic, but I can't figure it out.


    • Barton Cline
      Barton Cline

      Is that a typo, or am I missing something? Instructions for getting 0.5.1 from the CVS are in the thread entitled "compatibility with wxPython" in the Help Forum (under the "Forums" tab above. It works great with version 2.8.x of wx. (I'm using 2.4.4 of python)

      • Chelonian

        Barton, Boa 0.6.1. has been released.  I read the announcement on the wxPython mailing list, a message dated Jul 5 2007 by Riaan Boysen; here is an archived link to it:

        In that message Riaan indicated 0.6.1 can be gotten here:

        I've just begun fooling around with it (it did load fine on my computer, WinXP, Python 2.5 and wxPython  I'm not sure what the problem is regarding the MemoryLoadLibrary failure as galfip mentioned, though I have had problems like that on my older machines and it was due to a missing .dll file perhaps, and is true for many wxPython programs.  If I figure out more about how to fix it I'll get back here with that.  In the meantime if you just Google that error you'll find other people addressing that problem generally with wxPython. 


        • Barton Cline
          Barton Cline

          Thanks, Che. I updated from CVS. I was a bit nervous, changing the IDE in the middle of a big project, but all went well after a system re-boot. (I initially had a problem with Designer not knowing how to display frames, etc the correct size)

    • IloChab

      I had the same problem on a fresh windows 2000 installation.
      I solved it following this tip: