#50 wxWindows 2.3.1 != 2.3.0

closed-invalid
Riaan Booysen
None
5
2001-09-06
2001-09-06
Gregory Warnes
No

I discovered that the current release of Boa checks to be sure that
wxWindows is exactly 2.3.0. However, I'm using 2.3.1, so it would stop with
an error message.

Since I figure that higher minor revisions shouldn't break Boa, I modified
the code in Boa.py to allow this. Patch below. (BTW, is there a better
place to send these?)

-Greg

$ cvs diff Boa.py
Index: Boa.py
===================================================================
RCS file: /cvsroot/boa-constructor/boa/Boa.py,v
retrieving revision 1.23
diff -r1.23 Boa.py
109c109
< if (wxMAJOR_VERSION, wxMINOR_VERSION, wxRELEASE_NUMBER) != (2, 3, 0):
---
> if (wxMAJOR_VERSION, wxMINOR_VERSION, wxRELEASE_NUMBER) < (2, 3, 0):
113c113
< raise 'wxPython 2.3.0 required'
---
> raise 'wxPython 2.3.0 or later required'

Discussion

  • Riaan Booysen
    Riaan Booysen
    2001-09-06

    Logged In: YES
    user_id=438

    Nope I wasn't kidding. Boa requires 2.3.0 exactly. 2.3.1 has an accelerator bug. This check will be removed when
    2.3.2 comes out.

     
  • Riaan Booysen
    Riaan Booysen
    2001-09-06

    • assigned_to: nobody --> riaan
    • status: open --> closed-invalid