#10 no get* functions

closed-accepted
API change (4)
5
2004-08-27
2002-03-20
No

all of the blackbox API uses get*() functions,
which is too verbose in my opinion. remove the get,
and keep the function name the same.

Discussion

  • Ben Jansens
    Ben Jansens
    2002-03-20

    Logged In: YES
    user_id=166767

    I agree completely. I tried to request this before already :) Maybe with 2
    of us on this side it can happen.

     
  • Logged In: YES
    user_id=286178

    I third. =:)

     
  • Ben Jansens
    Ben Jansens
    2002-03-20

    Logged In: YES
    user_id=166767

    I agree completely. I tried to request this before already :) Maybe with 2
    of us on this side it can happen.

     
  • Logged In: YES
    user_id=37132

    there are places where the get is required, for instance in BScreen::getWorkspace. Sure we could rename it
    BScreen::workspace().

    My point is, 3 letters help differentiate things. I am willing to back down on this (I am currently out
    voted). I just want to show the other side of the coin.

     
  • Logged In: YES
    user_id=459209

    the libbt API is completely free of "get"

    blackbox itself will take more time

     
    • status: open --> open-accepted
     
    • status: open-accepted --> closed-accepted
     
  • Logged In: YES
    user_id=459209

    blackbox has been cleaned of get*() functions... simple accessors
    simply have a descriptive name (e.g. BlackboxWindow::workspace()).

    For things that need to calculate or verify something (i.e. it does more
    than simply return a value), I have used find* (e.g.
    BScreen::findWorkspace() and BlackboxWindow::findTransientFor()).