Hi Aleš,


I have run into the same problem. While we (that is, even Nils) were unable to pinpoint the exact source of the problem, it did not occur on all distributions.


I normally do the computationally intensive stuff on a 48-core machine running CentOS 5; this is where I get the same error message.


I’ve also built bfast on my 8-core desktop PC under OpenSuSE 12 – here, the indexing completes without errors. So I ran the indexing step on my desktop machine and all other jobs on the 48-core box.


Even if that should fail, there are probably quite a few people out there with indexed hg19 genomes (I was using bfast for Arabidopsis data, so I’m afraid I can’t help here), which they would likely be willing to share.




Steffen Uebe



Dr. rer. nat. Steffen Uebe

Humangenetisches Institut

Universitätsklinikum Erlangen

Tel. +49-9131-85-26101

Fax +49-9131-85-23232


Von: Aleš Maver [mailto:ales.maver@gmail.com]
Gesendet: Montag, 15. Oktober 2012 10:08
An: bfast-help@lists.sourceforge.net
Betreff: [Bfast-help] Error during BFAST indexing step


Dear bfast-help mailing list,

I have been trying to index human genome fasta file using bfast and I have been getting a new error during indexing step.


I would normally use this command for indexing:

bfast index -f hg19.fa -w 14 -m 1111111111111111 -n 16 -i 1


Soon after running this command, I get the following error:

Sorting by thread...

1.805 percent complete************************************************************

In function "RGIndexMergeHelperFromDiskGetNext_8": Fatal Error[ReadFileError]. Message: Could not read in buffer.

1.806 percent completeThe file stream error was:: Bad file descriptor

 ***** Exiting due to errors *****



I could perform this task previously without errors. I am quite sure the problem is somehow related to file permissions and the program fails when trying to read the .bfast.tmp* temporary files. I have been trying to fix this with setting the default system-wide umask, but I was still unable to make program run normally. 


I would be grateful for any hint regarding this issue and I wish you all a good day!

Ales Maver, MD
Institute of Medical Genetics, Department of Obstetrics and Gynaecology
UMC Ljubljana
Šlajmerjeva 3
SI-1000 Ljubljana
E-mail: ales.maver((@))gmail.com