#340 Misspecified version numbers (breaks maven ranges)

open
nobody
None
5
2012-06-26
2012-06-26
Anonymous
No

The org.beanshell.bsh version numbers are misspecified.

Rather than 2.0b5 it should be 2.0.5-beta (c.f. http://www.sonatype.com/books/mvnref-book/reference/pom-relationships-sect-pom-syntax.html\)

The current format of 2.0b5 does not work with maven version ranges - e.g. net.sourceforge.fmpp.fmpp-0.9.14 depends upon org.beanshell.bsh with a version range of [1.3,2.1), but since the release of 2.0b5, this no longer works as this cannot be understood as part of a range.

I\'ve also raised this issue with fmpp - c.f. https://sourceforge.net/tracker/?func=detail&aid=3537710&group_id=794&atid=100794

Discussion