#28 Unable to compile with database support

open
nobody
None
5
2005-06-02
2005-06-02
AMEE 2000
No

Hi!

I'm trying to compile bandwidthd with database support
but ./configure gives me the following error message:

"checking for PQconnectdb in -lpq... yes
checking for PQexecParams in -lpq... no
configure: WARNING: libpq exists but is too old...
bandwidthd requires support for PQexecParams"

I'm using libpqxx-2.5.3 which is afaik the most recent
version.
Output of a configure run is attached.
However, compiling without db support seems to work.

Can you tell me what I am missing or doing wrong, please?

Thankx,
Thomas

Discussion

  • AMEE 2000
    AMEE 2000
    2005-06-02

     
    Attachments
  • AMEE 2000
    AMEE 2000
    2005-06-02

    Logged In: YES
    user_id=1212900

    P.S: bandwidthd version is bandwidthd-2.0.1 and I'm running
    SuSE Linux 9.0

     
  • Logged In: NO

    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for bison... bison -y
    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for executable suffix...
    checking for object suffix... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for a BSD compatible install... /usr/bin/install -c
    checking for flex... flex
    checking for yywrap in -lfl... yes
    checking lex output file root... lex.yy
    checking whether yytext is a pointer... yes
    checking how to run the C preprocessor... gcc -E
    checking for X... no
    checking for /sw/lib... no
    checking for /sw/include... no
    checking for /usr/pkg/lib... no
    checking for /usr/pkg/include... no
    checking for connect in -lsocket... no
    checking for gethostbyname in -lnsl... yes
    checking for inet_aton in -lresolv... yes
    checking for pow in -lm... yes
    checking for libiconv_open in -liconv... no
    checking for png_read_info in -lpng... no
    configure: error: Bandwidthd requires but cannot libpng