Hello all,

I'm tring to restore data to a Windows client. This computer is in an Active Directory environment.

To backup Windows clients who are in this domain, I created a user with complex password and select "don't ask to change password", and I always use this user to backup data with backuppc.

Everything's working fine during backup, as I set DOMAIN\user and password for this user in the CONFIG/XFER tab. My host is set with DOMAIN\user in the "EDIT HOSTS\Hosts" tab.

When I select files to restore, I have 3 choices to restore. I choose the first option : direct restore to the host.

I set a new folder named "restore" to "restore the files below dir" which doesn't exist on the host, and the restore failed. Same thing if I create this folder on the host before start the restore process.

The user I use to backup Windows clients has write permissions on the Windows share.

Here's the error message :

Running: /usr/bin/smbclient \\\\host.domain.local\\d -U DOMAIN\\user-E -d 1 -c tarmode\ full -Tx -
Running: /usr/share/backuppc/bin/BackupPC_tarCreate -h host.domain.local -n 138 -s d -t -r / -p /restore/ /manifest.xml
Xfer PIDs are now 18818,18819
WARNING: The "idmap uid" option is deprecated
WARNING: The "idmap gid" option is deprecated
[ skipped 1 lines ]
tarCreate: Done: 1 files, 10923 bytes, 0 dirs, 0 specials, 0 errors
[ skipped 1 lines ]
This backup will fail because: abandoning restore
abandoning restore
Abandoning restore
restore failed: abandoning restore

When I run /usr/bin/smbclient \\\\host.domain.local\\d -U DOMAIN\\user-E -d 1 -c tarmode\ full -Tx - in ssh, a password is asked, so I think backuppc dosen't send the password which is used to backup the client ?

How to resolv this problem ?

Thanks a lot !