I am having this *exact* issue. However, I run a dedicated apache server for BackupPC that I compiled myself. No modules are loaded except mod_perl and mod_unique_id is not statically compiled either. I've never had issue with starting the apache server like yourself.

However, I do have the issue of hte BackupPC::Lib->new failed error requiring the backuppc daemon be restarted. 

I should mention that sometimes backuppc will run for weeks without issue, so you might not be out of the water yet (I hope you are!).

-james
Leopard Server 10.5.5, Dual Xserve G5

On Oct 15, 2008, at 2:51 PM, Huxtable, Brian R. wrote:

Iíve seen other users here have had this problem as well (judging from the archives) but there has never been a solution posted.  I believe that I have found the answer to this problem, somewhat accidentally:
 
In the process of setting up a script that would periodically check the BackupPC log for the ĎBackupPC::Lib->new failedí error, I needed to do several restarts of the server.  Apache wasnít starting on its own giving Ďnodename nor servname provided, or not known: mod_unique_id' in the error log.  Simply commenting out this module solved the apache startup problem Ö and also, apparently, the ĎBackupPC::Lib->new failedí error as well.  The script I wrote has not once fired a restart procedure since I commented out the module.  Previous behavior was that the error would crop up at least twice a day and persist until I restarted BackupPC.
 
Now, Iím not quite certain what mod_unique_id does but I havenít been using it in any other apache installation so I havenít been too worried to do the research.  If anyone would kindly explain any portion of this problem, Iíd be much appreciative.  I plan on writing a howto for BackupPC for Debian and Mac OS X and this piece of info would be pretty handy.
 
B
 
From: Huxtable, Brian R. [mailto:HuxtableB@msx.umsl.edu] 
Sent: Tuesday, October 07, 2008 10:13 AM
To: backuppc-users@lists.sourceforge.net
Subject: [BackupPC-users] Backup_dump - Wrong User
 
Iíve recently needed to reinstall BackupPC on Mac OS X 10.5 Leopard.  While it had worked previously on this platform, Iím getting some very odd errors that driving me insane:
 
Iím able to run backups for a period of time but some point in time during the day Iíll begin to get repeated iterations of the following:
 
/opt/local/BackupPC/bin/BackupPC_dump: Wrong user: my userid is 501, instead of  (tlctoor)
Please su tlctoor first
BackupPC::Lib->new failed
 
After I get this, newly initiated processes will fail but previously active processes seem to continue.  I then need to restart the BackupPC service to get backups back on track.
 
What am I missing, where should I look?
 
Brian
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/_______________________________________________
BackupPC-users mailing list
BackupPC-users@lists.sourceforge.net
List:    https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki:    http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/