Re: [BackupPC-users] recurrent backup failed' messages
From: Matthias Meyer <matthias.meyer@gm...> - 2010-07-29 20:12
Jack M. Nilles wrote:

> I'm moving BackupPC to a new machine, running SUSE 11.2. After
> installation I get nothing but the dreaded pink background and:
> 'backup failed (Unable to read 4 bytes)'
> messages for each host being backed up. Yet, if I start a backup via:
> 
> sudo -u backuppc /usr/local/BackupPC/bin/BackupPC_dump -v -f <host>
> 
> I do indeed get the backup, along with verbose output, provided I keep
> tabs on each backup section, since a password is required at each section.
> 
> What little detail am I missing here?

To tell us something about your configuration
 - connection to client (smb-share, ssh, rsync, ... )
 - xfermethod (smb, rsync, rsyncd, ... )
 - OS of client

The connections to clients are all ssh
Xfer method is rsync
Client OSes are OS X and Linux 

Currently I'm testing this by putting the backed up files on the server but plan to 
move them to a USB hard drive when all is in operating order.

The $Conf{RsyncShareName} entries usually have multiple entries; the BackupPC_dump 
fails during the transition from entry to entry if I'm not immediately there to input the root
password. The files are being backed up but it sure isn't automatic.

It almost seems like I'm getting timeouts and need to change some configuration setting 
to avoid it.

> I never had this problem with the 
> old machine running SUSE 11.1.

First of all -  
> 
> jackn

-- 
Don't Panic