Hi all, I hope you can help me.  
 
Ubuntu 12.04 x64
Backuppc v3.2.1
/var/lib/backuppc is mounted to a CIFS share off a IOMEGA NAS, and can read/write to it.  
 
Everything has been working fine for a while, but then the NAS got a different IP from DHCP (and after I got that set to static) I remounted the share, and was able to restart Backuppc once and run some Incremental backups (on Jan 25th).  A couple days later when I went to check it, something had crashed so I rebooted the server, remounted the share, tried to restart the service and when I went to the Web UI I saw this on the initial page (The Logo, Hosts Section, and Server Section menus were on the left of the page):

Error: Unable to connect to BackupPC server

This CGI script (/backuppc/index.cgi) is unable to connect to the BackupPC server on <Servername> port -1.
The error was: unix connect: No such file or directory.
Perhaps the BackupPC server is not running or there is a configuration error. Please report this to your Sys Admin.

 
Here is the recent output of /var/lib/backuppc/log/LOG:
 

2014-01-25 08:35:40 Finished incr backup on <servername>
2014-01-25 08:35:40 Running BackupPC_link <servername> (pid=6885)
2014-01-25 08:37:36 Finished <servername> (BackupPC_link rbafile)
2014-01-29 17:11:46 Reading hosts file
2014-01-29 17:11:47 unix bind() failed: Operation not permitted
2014-01-29 17:22:23 Reading hosts file
2014-01-29 17:22:23 unix bind() failed: Operation not permitted
2014-01-29 17:28:38 Reading hosts file
2014-01-29 17:28:38 unix bind() failed: Operation not permitted
2014-01-29 17:42:23 Reading hosts file
2014-01-29 17:42:23 unix bind() failed: Operation not permitted
2014-01-29 17:48:10 Reading hosts file
2014-01-29 17:48:10 unix bind() failed: Operation not permitted
2014-01-29 19:13:40 Reading hosts file
2014-01-29 19:13:40 unix bind() failed: Operation not permitted
2014-01-29 19:53:15 Reading hosts file
2014-01-29 19:53:15 unix bind() failed: Operation not permitted
2014-02-03 12:24:47 Reading hosts file
2014-02-03 12:24:47 unix bind() failed: Operation not permitted

 

The repetition is me trying to start the backuppc service over and over.

Can someone please point me in the right direction on what to look for or change to get this working again? Thanks!!