Error running under Vista/7RC with 64bit JVM

  • I am running Vista and Windows 7 RC (7100).

    I have installed both 32 and 64 bit JRE (version 6 update 13) VMs from Sun.
    So far this has played nicely with most of my Java applications, including Eclipse.

    However with AzSMRC 1.0.0, I receive an error report.
    Has anyone actually had success in getting AzSMRC to run on any 64 bit windows ?

    The log details are:

    java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
        at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
        at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
        at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
        at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
        at lbms.azsmrc.remote.client.swtgui.RCMain.init(
        at lbms.azsmrc.remote.client.swtgui.RCMain.start(
        at lbms.azsmrc.remote.client.swtgui.Starter.launch(

    Error ID 617655801d88eeecbb997e661edbc7c2acfdf5cc

    OS: Windows Vista
    JVM: 1.6.0_13 Sun Microsystems Inc.
    SWT Version: 3448 win32
    AzSMRC Version: 1.0.0

  • DrOctopu5

    I'm having the exact same problem. Windows 7 64-bit, AzSMRC 1.0.0. Same error.

    Have unzipped and replaced the swt.jar in the AzSMRC directory with the 64-bit SWT, no change. Still get the error.

    Is there some way to force it to be used? Or even force AzSMRC to use the 32-bit JVM? Kind of baffling.

    AzSMRC will still run after I click the error away, but it retains no preferences or server connection settings afterwards. It's a fresh run every time.

    Also, is this an abandoned project? Are people using Vuze Remote instead? (Not a fan.)

  • Well it is not exactly abandoned but it is not actively developed anymore, but I may look into it next week or so.