#248 Crash whenever I try to connect to msn

closed-fixed
MSN (42)
5
2009-10-16
2009-09-25
Michalis
No

I'm using ayttm 0.6.0 (the latest) which comes compiled and installed with the latest puppy 430.

Every time I try to connect to my msn account it crashes telling me that "connection to the server failed". Most of the time the system isn't responding after it and have to hard reset. With irc I don't have any problem.

I don't know if it is compiled using the option: --enable-posix-dlopen. I just want to fill this bug report in order to attach the crash log. If you need any more informations please ask for them.

Discussion

  • Michalis
    Michalis
    2009-09-25

    debug log

     
    Attachments
  • Hi Michalis,

    I have to admit I've known this issue since a few days now since pstef (one of our devs) uses puppy linux -- I've not had the time to set up a puppy linux box over the week. This is an odd issue because it's happening only on puppy linux but I didn't know it's bad enough to cause a hard system lockup. I'm loading it up today, so will try to find out what's amiss.

     
    • assigned_to: colinleroy --> siddheshp
     
  • Michalis
    Michalis
    2009-09-25

    siddheshp, thanks for the fast response :)

    Some more info, I hope that help:

    For first time today it didn't crash my system after asking it to close.
    One difference today that I observed is that it didn't asked me today if I wanted to accept a guy (I think a bot actually) in my network. All the other times after choosing not to accept there were appearing many tabs simultaneously, more or less 20+, asking me whether I wanted to accept him or not (the same as the first one) and then everything stopped responding except of the mouse pointer.

    Today it crashed with the message "connection to the server failed" left it be opened till I finished what I wanted to do and at the end when I wanted to close the pc I clicked the close button, and instead of crashing as I was expecting it just closed as normal.

     
  • Michalis
    Michalis
    2009-09-26

    Even more strange things happened today:

    1. First attempt to connect to msn crashed my system as usually. Nothing was responding so hard reset.

    2. Tried to open ayttm but wasn't running either from the chat icon, from the menu and from terminal. I searched why and the "prefs" file because of the crash was "stale nfs". That happens sometimes because of the aufs system. I used a method to delete it, ok that was puppys' problem related.

    3. Tried to connect to msn, crashed with the usual bug report. Before the crash again asked me about that person.

    4. Tried again to connect to msn, asked me about that person, no crash and connected perfectly!!!! Of course I wanted to dig it around and at some point that I wanted to change group to couple contacts in the second crashed with nothing responding except of the mouse pointer that was moving. Hard reset of course.

    5. Tried to connect to msn, asked me about that person (answer always no), no crash and connected perfectly!!!!!!! I started to play around, I connected also to irc, moved the rest of the contacts to the group I wanted, unloaded modules that I don't need (jabber, aim, yahoo), disconnected from everything and closed the program normally.

    6,7,8,9 I don't know how many times I tested it, I opened the program and worked fine no crash no nothing.

    I'm totally confused I don't know what changed, I didn't changed anything, didn't add any new program. The only thing that I've noticed today is that from my contacts only one is online (busy actually) today, normally they're more than 5. I don't know if that means something I'll see if is different at monday.

    Hope that helped and didn't confuse you more.

     
  • Hi Michalis,

    I tried ayttm on puppy yesterday and found and fixed a couple of bugs. This should include the friend request you keep getting as well as the crash. But I'm not sure about the latter. Would it be possible for you to check out the latest code from the repository, build and see if that works? The bug should hit on the first few runs with msn.

     
  • Michalis
    Michalis
    2009-09-26

    Ok I'll do it and will report back in monday or tuesday.

    By the way now again is working fine and I have also many contacts online. Magical fix...

     
  • Michalis
    Michalis
    2009-10-06

    I tested 0.6.0-4 for 3 days and hadn't had any crash. Afterwards I compiled also 0.6.0-6 which is the one I'm using now and with this version I had some random crashes. One of those crashes was serious and locked the X server, I had to hard reset the system. All the others, about 5 out of 30 starts and thous not every time I was trying to connect, happened when trying to connect to msn. The program was connecting to the msn but during the loading of the contacts the program was reporting that "connection to the server is lost" and was receiving signal 11. So is something that has to do with the connection for the first time, since every time I tried to reconnect everything was perfect.

    Something else that I noticed is that when choosing in the preferences to unload a module next time the program starts has all the modules loaded again. Seems like it doesn't remember in the preferences whether the user has chosen not to use some modules. I even manually edited the prefs file and next time wasn't working.

     
  • Can you enable debugging for msn and then try logging in? You will find the preference for that in Edit > Preferences > Services > MSN.

    Once you check the "Enable debugging" check box and press Ok to save, restart ayttm with the following command from console:

    ayttm 2> ayttm.debug

    and then try to connect to reproduce the crash. Once it crashes, open the ayttm.debug file and search for your password. Replace the password with junk or simply remove it and then attach the log file here. This will also contain your buddy list information, so let me know if you're not comfortable sharing that here. You could even email it to me using my SF.net email (username at users.sourceforge.net)

    As for module unloading bit, I'll look at that and let you know.

     
  • Michalis
    Michalis
    2009-10-08

    Ok I sent it to your e-mail.

     
  • I have not got the email yet, maybe it's on the way in the internet tubes :) I have put in a couple of more fixes for MSN, one of them might be related. Can you test with the latest from git? I'll hopefully understand the exact problem once I see the debug logs.

     
  • Michalis, thanks for the logs. I can see three bugs based on the logs
    * Contact sorting is incorrect when I send them back to the server. I guess this should not cause any problems but I just want to be sure anyway
    * Your nickname has spaces, which should be urlencoded
    * An x windows system error, which should likely be caused by some gtk/gdk/X bug rather than ayttm itself. This is also likely to be the cause for the hard lockup that you experience. Ok, I just realized that I'm using puppy 4.2.1 and hence probably not seeing the lock-ups

     
  • I've put in a fix in git to cater for spaces and special characters in a friendly name. The sorting order for contacts does not matter, so I'll leave it at that for now. I'll download a puppy 4.3.0 ISO and test to see if I can reproduce the X error.

     
  • Works alright for me with puppy 4.3.0 and the latest changes.

     
  • Michalis
    Michalis
    2009-10-16

    Sorry for not responding earlier but I was to busy this week.

    I'm testing during the last days the new puppy 4.3.1 RC2 witch has the latest ayttm 0.6.0-9 installed. Everything works perfect. Only once I faced the problem where the program closed, but I restarted it and connected without problem. Seems that the problem occurs very rarely and under unsure circumstances. I tend to believe after the debug messages that mainly occurs due to puppy rather than ayttm.

    So you can say that this bug is resolved. Thank you very much for your effort, your response is the best I've seen from any developer to a bug report. :-)

     
  • Closing as per previous comment. Thanks Michalis :)

     
    • status: open --> closed
     
    • status: closed --> closed-fixed