#1745 IIS 7.0 Log Format Issue


I've set this up to work on serveral sites on my WinServer2008 using iis 7.0.
Used all the recommended setting etc for log format and similar on iis.
This worked no problems really.
A few hours later now one of the sites refuses to update complaining of corrupted records.
I noticed that the log records were no in the same order as the documentation suggested,
so I've played with the log format to try and get them to match with no success.

Any Ideas?

log format from iis log file:

Fields: date time cs-method cs-uri-stem c-ip cs(Referer) sc-status sc-bytes

awstats config file
LogFormat = "%time2 %methodurlnoprot %host %referer %code %bytesd"

Error dump
C:\inetpub\WebStats>perl awstats.pl -config=f5d -update
Create/Update database for config "./awstats.f5d.conf" by AWStats version 6.9 (build 1.925)
From data in log file "C:\logs\f5d\W3SVC4\u_ex090527.log"...
Phase 1 : First bypass old records, searching new record...
Direct access after last parsed record (after line 66)
AWStats did not find any valid log lines that match your LogFormat parameter, in the 50th first non commented lines read of your log.
Your log file C:\logs\f5d\W3SVC4\u_ex090527.log must have a bad format or LogFormat parameter setup does not match this format.
Your AWStats LogFormat parameter is:
%time2 %methodurlnoprot %host %referer %code %bytesd
This means each line in your web server log file need to have the following personalized log format:
%time2 %methodurlnoprot %host %referer %code %bytesd
And this is an example of records AWStats found in your log file (the record number 50 in your log):
2009-05-27 18:44:45 GET /f5dforum/styles/prosilver/theme/images/icon_logout.gif http://www.f5d.co.uk/f5dforum/ 304 211
Setup ('./awstats.f5d.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).



  • Some further investigation is that it doesn't seem to like the urls with lots of slashes?