Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

IIS8 & AWSTATS Permissions

A New User
2013-05-20
2013-07-20
  • A New User
    A New User
    2013-05-20

    System: Windows Server 2012 IIS8

    I installed AWSTATS Version: 7.1.1

    awstats.domain.com.config is created with these settings:

    LogFormat = "date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken"
    LogSeparator = " "
    DNSLookup = 2
    DirCgi = "/cgi-bin"
    DirIcons = "/icon"
    AllowFullYearView=3
    AllowToUpdateStatsFromBrowser = 1
    UseFramesWhenCGI = 1
    ShowFlagLinks = "en fr de it nl es"
    LogFile = "C:\HostingSpaces\domain.com\logs\W3SVC8\u_ex%YY-3%MM-3%DD-3.log"
    DirData = "C:\AWStats\data"
    SiteDomain = "domain.com"
    HostAliases = www.domain.com

    When I go to http://awstats.domain.com/cgi-bin/awstats.pl?config=domain.com

    The whole pages loads with no stats. On the top it says this:

    Last Update: Never updated (See 'Build/Update' on awstats_setup.html page) Update Now (link)
    I click the Update Now link which takes me to the next page where I am hit with this error:

    Error: Couldn't open server log file "C:\HostingSpaces\domain.com\logs\W3SVC8\u_ex130520.log" : Permission denied

    There are a number of log files, one for each day in this folder W3SVC8.

    What do I have to do to get this working?

     
  • K-CO
    K-CO
    2013-07-12

    hi,

    seems,you never launch an update on your logs.manually do from a command line :

    pathtofill> awstats.pl -config=your_site_name -update

    This should better work manually.

    With the 'update link' on your page, it's another problem.

    Hope this help you ^^

     
  • RichF
    RichF
    2013-07-20

    Even manually, he will still have issues with permissions on the log file.

    You have to grant permissions (755) on the log file, or even more open. Or make sure the nobody user is in the wheel group.

    Permissions are a sucker with this application. I'm also looking for answers.