Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

URLWithQuery and URLReferrerWithQuery problem

2010-09-21
2014-05-06
  • This is a strange one, and it could entirely be something I'm doing, but I
    need to make if it is or isn't. We have several conf files running on
    different log files, and the one that we are having the problem with is an IIS
    log. When I run stats manually, it successfully includes all the strings at
    the ends of the URL's. This is what we want. But when my automated process
    runs (using the exact same conf file) it acts as if the URLQuery commands are
    set to 0 and it combines all those stats into one link.

    "perl ""C:\www\html\admin.worthingtonlibraries.org\webstats\cgi-
    bin\awstats.pl"" -config=xxx.xxxxxxxxxx.org.public -update"

    That is the automated command that is running. It is the same command that I
    run manually. All the stats run, except when the automated one runs it seems
    to ignore the query strings. Any ideas? Even where to start. Right now I am
    manually running this particualr one because the stats are not what we want
    when it runs automatically. Thanks.

     
  • Jean-Luc
    Jean-Luc
    2010-09-21

    Hi,

    Very strange. There are a few things to check though:
    - make some small changes in the config file just to be sure the update is using the config file you think it uses
    - preferably use absolute paths for LogFile and DirData in the AWStats config file
    - try again without the quotes around C:\www\html\admin.worthingtonlibraries.org\webstats\cgi-bin\awstats.pl (quotes are needed only if the path contains spaces)

    Jean-Luc, InternetOfficer AWStats
    Support

     
  • Thanks Jean_Luc. I appreciate the things you mentioned, and I tried them.
    While those didn't resolve the problem all together, it did put me on the
    right path, and I figured out why this was happening. Out of a natural habit,
    manually, I always convert the IIS log to an Apache log, because we have
    several scripts that just run on the Apache logs. Of course, this particular
    log, is the only log file that the Awstats conf file runs on the IIS log
    instead of the Apache log. When I do it manually, I manually alter the conf
    file to run on an Apache log. I hope that all makes sense. So the REAL problem
    is, this is the logformat I have running against the IIS log..LogFormat=date
    time cs-method cs-uri-stem cs-username c-ip cs-version cs(User-Agent)
    cs(Referer) sc-status sc-bytes...you'll notice there isn't an entry for query
    in there. So I am researching where I need to put in the appropriate entry so
    it will allow the query part to be recognized, thereby hopefully allowing
    Awstats to use the URLWithQuery piece.