Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

All data are 0's yet import worked.

Lraymond
2013-08-14
2013-08-14
  • Lraymond
    Lraymond
    2013-08-14

    Evening all. I followed a simple howto, running on Ubuntu 12.04LTS, did a binary apt-get to install, and configured 2 domains by hand. Command line to update worked, one domain had a lot of data so I merged all the old files to one to do that, and I got the following;

    Parsed lines in file: 286360
    Found 0 dropped records,
    Found 0 comments,
    Found 0 blank records,
    Found 1 corrupted records,
    Found 286359 old records,
    Found 30 new qualified records.

    The other is a newer site, had 22 qualifying records, but the problem is when I visit either domain/awstats/awstats.pl, the site shows, domain is correct, but everything is just 0's.

    I haven't run awstats on this server so not sure why they show as old, but also even more disturbing is why the values are all 0's. The Last Updated shows Never Updated, so I enabled browser updates. When I click that I get the following error;

    Error: Couldn't open server log file "/var/log/apache2/mydomain.log" : Permission denied

    Setup ('/etc/awstats/awstats.mydomain.com.conf' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).

    The apache log is -rw-r--r-- 1 root adm
    The config file is -rw-r--r-- 1 www-data www-data

    Apache is running as www-data, so I am not sure what the problem is.

    Thanks for all read/replies.