Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

awstats postfix dropped records

2004-09-21
2012-10-11
  • Hello,
    In order to investigate I used "pflogsum" stats tool to see if my logs in /var/log/maillog were correct.
    It works fine, the reprt generated gives me correct stats.
    So, it seems the problem comes from the result produced by maillogconvert.pl or mlc anr my LogFormat.
    My LogFormat is the one given in the doc.
    An example of log in /var/log/maillog is :
    Sep 21 10:04:10 mailserver.org postfix/smtpd[16497]: 4GTD2145876: to=<christophe.husson@organisation.org>, relay=server.org[192.168.5.7], delay=0, status=sent (250 OK)
    Any idea ? Many thanks

     
    • What's your logformat like?

       
  • LogFormat="%time2 %email %email_r %host %host_r %method %url %code %bytesd"

     
  • stop postfix first, clean out your mail log and restart the stats page. thats what i did and it works

    TT

     
  • Hello,
    what I did :
    On my remote postfix server I commented directive @serverawstats in syslog.conf and restarted syslog.
    on my server awstats :
    rm /var/log/maillog
    touch /var/log/maillog
    chmod 640 /var/log/maillog
    On my remote postfix server :
    add in syslog.conf : mail.* @serverawstats
    restart syslog
    on my awstats server
    /usr/lib/cgi-bin/awstats.pl -configure=mydomain.org -update
    result :
    0 dropped ; 0 corrupted ; 0 old ; 0 new
    I can mail you my whole awstats config file and an extract of my /var/log/maillog if you wish.
    regards
    Christophe.

     
  • husson
    husson
    2004-09-23

    According to my previous post, I just posted my awstats.organisation.org.conf and /var/log/maillog files to tfranzke@sourceforge.net
    regards,
    Christophe.

     
  • the problem is solved,
    the daemon qmgrd in postfix did not log anymore the "from" mail address and thus it did not match awstats LogFormat. Restarting Postfix solved the problem.
    Christophe.