%http_proxy problem

Jeremy
2010-12-02
2012-10-11
  • Jeremy
    Jeremy
    2010-12-02

    Hi,

    I am having problems with proxy generated logs. Though they have been working
    for a couple of weeks, starting yesterday my logs aren't being processed by
    awstats anymore.
    This is the error I'm getting:

    AWStats did not find any valid log lines that match your LogFormat parameter,
    in the 50th first non commented lines read of your log.
    Your log file /var/log/webfrontends.log.1 must have a bad format or LogFormat
    parameter setup does not match this format.
    Your AWStats LogFormat parameter is:
    %other %other %other %other %other %virtualname %host_proxy %time1 %methodurl
    %code %bytesd %refererquot %uaquot
    This means each line in your web server log file need to have the following
    personalized log format:
    %other %other %other %other %other %virtualname %host_proxy %time1 %methodurl
    %code %bytesd %refererquot %uaquot
    And this is an example of records AWStats found in your log file (the record
    number 50 in your log):
    Dec 2 12:05:05 ip-10-228-29-221 apache2: www.funweek.it 142.35.45.220,
    142.22.16.51 "GET /img/bg_bottom_banner_strip.gif HTTP/1.0" 200 707
    "http://www.funweek.it/home/brutto-periodo-per-gli-u2-il-loro-musical-
    stronca.php
    " "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET
    CLR 1.1.4322; .NET CLR 2.0.50727)"

    Can anybody explain where the problem is?

    Thanks,
    Jeremy

     
  • Jeremy
    Jeremy
    2010-12-02

    The problem is in the date format.

    "Dec<space><space>2" is incompatibile with the single space LogSeparator (="
    ") while two-digit days (ex. "Nov 27") is OK.
    I had to change the rsyslogd logging format to get it working.

     
  • Jean-Luc
    Jean-Luc
    2010-12-02

    Hi,

    This directive in the AWStats config file should work too :

    LogSeparator="\s+"
    

    Jean-Luc, InternetOfficer AWStats
    Support