#857 Syntax error in geoip plugins

open
nobody
5
2012-10-11
2011-03-14
chuck
No

This was reported on launchpad:

In the files /usr/share/awstats/plugins/geoip_city_maxmind.pm and geoip_region_maxmind.pm there is an unescaped ampersand: 'AE',"Armed Forces Europe, Middle East, & Canada"

When outputting an Awstats report via /awstats.pl?output=plugin_geoip_city_maxmind in XHTML this creates a syntax error and the page cannot be displayed. Please change the & to &

Discussion