#838 GeoIP Cities page doesnt work from awstats 7.0

7.0
open
nobody
5
2013-12-07
2011-01-02
Jan Vitek
No

All records go into single row "Unknown" from Awstats 7.0 in GeoIP Cities page. Awstats 6.95 didnt have this problem - GeoIP Cities page had many rows with info about countries/regions/cities. I am attaching a simple patch that fixes problem for me.

Discussion

  • Jan Vitek
    Jan Vitek
    2011-01-03

    I have found new problem with GeIP Cities under Awstats 7.0. Regions column was always empty. I am attaching new patch that solves both problems.

     
  • Jan Vitek
    Jan Vitek
    2011-01-03

  • Bryan
    Bryan
    2011-02-23

    Hello,

    This patch works great, and is just what I needed. Thanks for doing this!

    -Bryan

     
  • Anton Voloshin
    Anton Voloshin
    2011-03-29

    I second the presence of this bug and usefulness of this patch: I did discover the same bug independently and had to make a similar fix to get it working.

    awstats committers: please accept the patch from jvitek, it's good as far as I can tell.

     
  • Peavy
    Peavy
    2011-09-01

    Thanks guys for the patch, really helpful !
    Hope it will be added to the next version of AwStats !

     
  • The file geoip_city_maxmind.pm is unchanged on 7.2 version.
    The patch gives by Jan Vitek (https://sourceforge.net/p/awstats/bugs/838/#dfb4) works very well.
    I suggest to verify if this bug is again there on 7.2 and then to apply the patch.

     
    Last edit: Christian MOMON 2013-12-07
  • Patch will be added for next stable version