Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo


still having add movie problem with 0.9pre7

  • Argument "O_RDONLY" isn't numeric in sysopen at Aviman/CGI/Init.pm line 111

    this is the error that shows in my error log, when I try to add a movie after login in.  It also boots me back to the login page.

    • can you test current CVS in a few hours? You have to replace *.pl , Aviman/CGI/Init.pm and the default theme!

    • Still have the same problem, however the error in my apache log is not there anymore.  When I go to add a movie as admin (or any other user) I get booted right back to the login page.  Just pulled CVS this morning ( 10-17-2005)

      • this problem only occurs at the add movie page??? everything else works?

    • I login as admin (or any other user with proper priv) and when I click on the "add movie" link in the lower left , I get sent back to the login page.  This also happens whenever I try any of the links in the "admin" section.

    • this looks like problems with the sessions. could you ty a fresh installation with the installer script in 0.9pre9? this script should fix typical installation problems (wrong paths and permissions).

    • OK, downloaded pre9.  Removed all of my old files /cgi-bin/aviman and /htdocs/aviman .. ran the installer perl install.pl -u nobody -c /var/www/cgi-bin/ -d /var/www/htdocs/ (this will work for slack 9.0 + BTW) and I still get the same problem.  I can login , but if i try to do anything i get bumped back out to the login screen.

      • thanks for trying pre9.

        ok, sessions are not working. please check:

        are there any sessions saved in cgi-bin/data/tmp?

        if not, why? permissions? wrong path in cgi-bin/Aviman/CGI/aviman_cgi.ini?

        is there a cookie (FF: Edit->Preferences->View Cookies)?

    • Here is what i have set in aviman_cgi.ini:
      sessions =/var/www/cgi-bin/aviman/data/tmp

      and here are the permissions on that dir:
      drwxrwxrwx    2 nobody   nogroup        80 Oct 31 12:14 tmp

      no session files are showing up , and I can su to user nobody and create / modify / delete files in that dir so permissions are ok.

      And there is a cookie set for CGISESSID. in my browser (i am using firefox)

    • I am having the same problems as above. I am running 0.9pre9 and am not getting a session file in my tmp but I do get the cookie set for localhost with the cgi session id. Has anyone figured out a solution?


      • ok, I am getting a session id in my session folder but it still sends me back to the login screen when I click on a link after logging in. Any Ideas?