please help with installing on mac os x

  • nick Miller
    nick Miller

    I hope someone can help me with my installing issues with auto-07p.  Here is my situation:  I'm using an intell macbook pro and trying to install auto.  I have downloaded the thing, unpacked it, and i am trying to configure the install with ./configure -enable-gui. 

    now, the issue is that auto requires some libraries for the gui and plotting utility which the configure script isn't finding.  it needs Motif (libxm), Coin3d and SoQt.  I installed these things, and i can see the Inventor.framework (for coin3d) and SoQt.framework folders in the /library/frameworks/ folder.  I also see the /usr/OpenMotif/lib/ folder, so i think these dependencies are installed. 

    now the motif install instructions said that i need to add the /usr/OpenMotif/lib/ path to the DYLD_LIBRARY_PATH environment variable.  I did this, but may have replaced the environment variable instead of adding to it.  What is the default or proper value for this variable?

    In spite of the presence of these dependencies, the configure script still doesn't find them.  What can i do to fix this?

    thanks for your help.