Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

segment length issue

Help
2008-09-12
2013-04-01
  • I am using slicer to cut up some full length albums I burned to .mp3 back when the earth was still cooling. I am using iTunes as my playback of choice.

    When I go ahead and export my slices everything looks just fine but when I put them into iTunes the times are all borked. The first cut lists as being the same length as the original recording, and the other lengths are just... off. One today had the third cut being over 50 minutes... when it was more like six.

    If I take these same files and open them with Quicktime and with making no other changes, save them as a .mov file and *then* bring them into iTunes, the times are all just fine... but they are also .mov files.

    I am running 10.5.4 on a Mac Mini and importing into iTunes 8. (That said, I had the same issues running the last version of iTunes 7)

    Any idea why this is happening and what I might do to fix this without needing to run a batch process through Quicktime with every sliced album?

     
    • oobleckboy
      oobleckboy
      2008-09-13

      I'm having the same problem, but quicktime does NOT fix the problem. If I trim the dead space at the end of a song using QT then import to iTunes, it often gives me a ridiculously long running time.

       
      • I am not trimming anything, just opening the slice in Quicktime and then saving it directly.

        I would think that given *your* problem that AudioSlicer would be able to sense the silence you are trying to get rid of and go ahead and cut it off as a separate segment that you throw away after the fact.

        I am guessing that you are using Quicktime Pro?

         
        • oobleckboy
          oobleckboy
          2008-09-13

          Yes, QT pro with OS X 10.3.9

           
    • jmoe2k
      jmoe2k
      2008-09-26

      I'm having the same issue.
      Another work around is to open in ITunes, right click on the track and select "Create MP3 version" (or AAC version depending on what your import preferences are set to). This creates a copy with the correct duration.

       
      • In the intervening week I found the same solution. It also works for the slices I made in Quicktime where there wasn't an actual silence long enough to trigger a slice... it will translate .mov files just like any other files.

        I *do* go ahead and change my import settings when I do this however because I have them set to Apple Lossless (for new media) and since these are all old .mp3 files, they will never be better than that, so saving them in a format that makes one think they are of a better quality would probably come to bite me in the ass someday.