Hmm, that's odd. What version of Debian are you running? I compiled audacity the other day just fine.

From: Steve the Fiddle
Sent: ‎Monday‎, ‎July‎ ‎28‎, ‎2014 ‎9‎:‎07‎ ‎PM
To: audacity-devel@lists.sourceforge.net

On 29 July 2014 02:20, Leland <leland@audacityteam.org> wrote:
> On 7/28/2014 7:28 PM, Steve the Fiddle wrote:
>> As far as I'm aware there has still been no resolution to the issue
>> that Audacity does not build on Debian with the default configure.
>>
>> To build Audacity on Debian it is necessary to build with
>> --disable-dynamic-loading
> What happens Steve?  I just tried it on Mint 17 Mate using the
> instructions from the URL you gave and it build just fine.
>
> Leland

The full story is on the -devel list (link below), but it's very long
http://audacity.238276.n2.nabble.com/build-failure-on-Debian-from-revision-13110-onward-tt7561996.html
so to save time I've attached the full build log when building with:

./configure 2>&1 | tee build-log
make 2>&1 | tee -a build-log

Steve