That's a bit disappointing!

I don't really want to have to revert to a previous OS as I think that would be a major headache.

I already have the command line tools installed (not sure which version). Any idea why
 the 4.5.2 command-line tools are required?

Cheers,

Chris




From: Gale (Audacity Team) <gale@audacityteam.org>
To: audacity-devel@lists.sourceforge.net
Sent: Tuesday, 29 July 2014 9:38 AM
Subject: Re: [Audacity-devel] Mac Build Questions

Chris Share-2 wrote
> Hi,
>
> I'm interested in building Audacity on OSX. I'm a reasonably experienced
> C/C++ programmer. I'm currently doing some audio editing work so my main
> interest is in adding features that will help me with my editing, however
> I'd also be happy to fix bugs, etc.
>
>
> I've found the instructions at
> &lt;http://wiki.audacityteam.org/wiki/Building_On_Mac> however I'm a
> bit unclear as to how to proceed on an up-to-date OSX Mavericks.
>
> Here's my configuration:
>
> OSX Mavericks 10.9.4
> Xcode 5.1.1
> pkg-config 0.28
> cmake 2.8.12.2
>
> What I'm not clear about is which of the older versions of Xcode I need to
> install?
>
> Do I need:
>
> “Xcode 3.2.6 and iOS SDK 4.3” dmg and “Xcode 4.5.2” dmg?
>
> If I install these will they overwrite my existing version of Xcode? If
> possible I'd like to keep my existing version of Xcode so I'm a bit
> reluctant to do this.
>
> Any help with this would be much appreciated.
>
> Cheers,
>
> Chris

Mavericks won't officially (or even probably unofficially) let you install

Xcode

below 5.x. See https://discussions.apple.com/thread/5537927?tstart=0 for all
I have managed to find out about it. The last post in that thread says you
can
install Xcode 3.2.6 if you uncheck "Unix Development" in the 3.2.6 installer
but
"Unix Development" is a required step for building Audacity. 

So my current understanding is that the process on the Wiki only works for
Mavericks if you install Xcode 3.2.6 and the 4.5.2 command-line tools on
pre-Mavericks, then update to Mavericks and update Xcode to 5.x. You "may"
be able to install 3.2.6 and 5.x on Mountain Lion then upgrade to Mavericks
without further Xcode upgrade but that is untested.

Again as I understand it, the requirement for Xcode 3.2.6 arises from our
continued support of PPC Mac. Personally I think it would be OK to drop PPC
support now as long as that did not mean also dropping support for OS X
10.6, which still accounts for one in five of all Macs. 


Gale



--
View this message in context: http://audacity.238276.n2.nabble.com/Mac-Build-Questions-tp7562445p7562451.html
Sent from the audacity-devel mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Infragistics Professional
Build stunning WinForms apps today!
Reboot your WinForms applications with our WinForms controls.
Build a bridge from your legacy apps to the future.
http://pubads.g.doubleclick.net/gampad/clk?id=153845071&iu=/4140/ostg.clktrk
_______________________________________________
audacity-devel mailing list
audacity-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/audacity-devel