Request: Prefetching

Discussion
MtlDvl
2012-01-05
2012-10-09
  • MtlDvl
    MtlDvl
    2012-01-05

    Hi,

    This topic has been touched shortly before in another post concerning
    accessing music files from external devices, but this problem is not solved by
    following the steps described in the other post.

    The problem is that I'm accessing my Flac music collection located on a NAS
    drive via a wireless network connection. Not the most ideal setup, I know, but
    this is the only possible configuration as it is now. I've turned on the
    "cache files before playing" option and disabled the "use shot path names for
    Mplayer" option. But transferring 20-30 MB. media files before playing them
    results in an 8-10 seconds gap between each number on my playlist.

    What I'm proposing is a prefetching option (or read ahead) like some image
    viewers will do, to try to keep a steady flow. So while track 1 is playing,
    Atunes will start reading track 2 and so on, resulting in gapless playback.

    Otherwise Atunes is working flawlessly for me, so thanks for that. Love the
    program. :)

    By the way, if you're bug-fixing anyway, I just noticed, that if you pin the
    Atunes program icon to the Windows 7 taskbar, the Atunes icon will change to a
    default Java icon.

    Hope you'll look into this. (Not the icon thing, but the other one ofc.) ;)

    Best regards
    MtlDvl