Stable and RC version cannot start (debian)

Discussion
Anonymous
2010-04-08
2012-10-09

  • Anonymous
    2010-04-08

    Hey guys, i tried to install atunes on my debian system, i have java, mplayer
    all kinds of codecs and etc, but it cannot start, i tried from the .deb
    packages and the tar.gz archive, all i got is this message

    INFO Starting aTunes 1.13.6 Autan (Build 547 )
    INFO Running in Java Virtual Machine 1.5.0
    INFO Arguments =
    INFO Debug mode = false
    INFO Execution path = /usr/share/atunes/
    ERROR --> Main$1.uncaughtException Thread: main
    ERROR --> Main$1.uncaughtException java.lang.NoClassDefFoundError:
    net.sourceforge.atunes.kernel.modules.podcast.PodcastFeedHandler
    ERROR --> Main$1.uncaughtException
    java.lang.Class.initializeClass(libgcj.so.10)
    ERROR --> Main$1.uncaughtException
    net.sourceforge.atunes.kernel.Kernel.startKernel(Unknown Source)
    ERROR --> Main$1.uncaughtException net.sourceforge.atunes.Main.main(Unknown
    Source)

    Thank you! :)

     

  • Anonymous
    2010-04-08

    Тhe above was in the log file, i;ve deleted everything in ~/.atunes/ , аnd now
    i got this

    Exception in thread "main" java.lang.NoClassDefFoundError:
    net.sourceforge.atunes.kernel.modules.context.ContextHandler
    at net.sourceforge.atunes.kernel.Handler.<clinit>(Handler.java:73)
    at java.lang.Class.initializeClass(libgcj.so.10)
    at java.lang.Class.initializeClass(libgcj.so.10)
    at net.sourceforge.atunes.Main.main(Main.java:87)

     
  • fleax
    fleax
    2010-04-10

    According to your log you are not using a java virtual machine from Sun. It's
    recommended to use a Java 6 JVN from Sun.

     
  • Macolin
    Macolin
    2010-04-13

    Remove Java/OpenJDK 5 and replace with version 6 (available from Synaptic).
    aTunes requires at least Java/OpenJDK 6.