Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

unable to play the game

Help
2007-01-26
2012-12-06
  • Hello,

    I have installed Attal (0.10.1+cvs20060815-0ubuntu1) on XUbuntu 6.10.

    It's been impossible to play the game.  The attal-server and the attal-client
    binaries are starting,  but after choosing a scenario(in the server) and
    connecting the client to teh server,  the map remains black  and there is a
    text message saying that "it's not your turn" .

    I suspect that the following error messages are showing a communication problem:
      ERROR:               handleSocket (l.  561): Unknown socket_class

    Any idea about what might be the problem?

    Adrian

     
    • If i have well understood, the game come from CVS of 25/08/2006

      In cvs now all is included in client, so to start game you need only to start client and press start game.
      Here you can choose between multiple scenarios.
      Good game.

      C.

       
    • That is the version included in the name of the package. I haven't compiler it
      myself,   and i haven't seen the version anywhere inside the game (normally the
      "About" box should contains the version in most applications).  So i am not 100%
      sure about what version is it.

      So, you are saying that the newest versions are no longer separated in attal-server and
      attal-client?

      I have tried to "start game" and choose a scenario , but the game does not start. I
      mean : the map is still black.

      I have tried to run it in all the possible ways i could think of. No success.

       
      • I don't know could you post exacty debug messages?
        Have you the themes installed?

        C.

         
    • The debug messages are visible if I start the executables from a console. I haven't
      done anything special to enable them.

      Yes, a theme package was installed. I'm saying "was" installed because I've given
      it up.