#162 Division by zero bug in three.asy

v1.0 (example)
closed-invalid
O. Shardt
three.asy (1)
5
2014-05-16
2013-10-21
sn6uv
No

I think there's a division by zero bug in three.asy around line 2906:

/usr/share/asymptote/three.asy: 2906.13: runtime: division by 0 in transform of a triple

Confirmed in version 2.24 up to the current development branch 2.25svn-r5576

Possible duplicate of #160?

1 Attachments

Discussion

  • John Bowman
    John Bowman
    2014-04-17

    What platform (hardware, 32/64 bit, OS) does this occur on?
    I haven't managed to reproduce it yet...

     
  • John Bowman
    John Bowman
    2014-04-18

    • status: open --> closed-works-for-me
     
  • John Bowman
    John Bowman
    2014-05-14

    • status: closed-works-for-me --> open
     
  • John Bowman
    John Bowman
    2014-05-16

    This appears to happen only with positive values of -render. If one ignores the error and returns the argument untransformed, a completely black rendered image results.
    This indicates the problem is a faulty glut or glu rendering library, nothing to do with Asymptote.

     
  • John Bowman
    John Bowman
    2014-05-16

    • status: open --> closed-invalid