Hi all !!
 
I have the following problem:
 
I compiled Linux 2.4.19 with patch patch-2.4.19-rmk7.gz
 
Now when I want start that kernel with armboot v1.1.0 i get the following lines on my console:
 
epxa1db # tftp a00000 zImage.bin3
smc91111 mac addr: 0:7:ed:0:0:45
ARP broadcast 1
eth addr: 00:02:44:40:01:f7
TFTP from server 192.168.88.101; our IP address is 192.168.88.247
Filename 'zImage.bin3'.
Load address: 0xa00000
Loading: ###########################################################
done
Bytes transferred = 300016 (493f0 hex)
epxa1db # bootm a00000
## Booting image at 00a00000 ...
   Image Name:   linux
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    299952 Bytes = 292 kB = 0 MB
   Load Address: 00a00000
   Entry Point:  00a00000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
 
Starting kernel ...
 
Uncompressing Linux........................ done, booting the kernel.
and here the board hangs :-((
 
But when i use armboot v1.0.2 witch i found on the MontaVista Linux Preview Kit for Prof. Edition 2.1, then the same Kernel boot as i want !!!
 
And now i'm a littlebit confused - it looks like that armboot v1.1.0 has a problem with my kernel ?!?
Are there any changes between armboot v1.0.2 and v.1.1.0 that cause such a problem? Or are there some spezial Environment Variable which must be set...
Has anyone an idea how i could track down this problem??? (I think the problem is located in armboot - or not??)
 
Thanks for all advice in advance....
have a nice day ;-))
Schachinger MArtin
 
 
--
Martin Schachinger
DECOMSYS - Dependable Computer Systems
Stumpergasse 48/28, A-1060 Wien, Austria
Phone: +43 1 59983-91
Fax: +43 1 59983-18
mailto:schachinger@decomsys.com
http://www.decomsys.com